summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2009-09-03 03:00:38 -0700
committerSteve Langasek <vorlon@debian.org>2019-01-08 21:26:01 -0800
commitc86e81c1b52419226501205c9f18b6e3979dcb19 (patch)
tree9d7bcd33c1f871a881d4e443611e64459d855a05
parent141d169fd95f29cc084c7498872d1b7721e33100 (diff)
make sure we only munge the unix_chkpwd perms when we're not in a binary-indep
target
-rwxr-xr-xdebian/rules2
1 files changed, 2 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 226bb03d..b0c0e1ca 100755
--- a/debian/rules
+++ b/debian/rules
@@ -49,8 +49,10 @@ override_dh_installman:
# dh_fixperms doesn't want
override_dh_fixperms:
dh_fixperms
+ifeq (,$(findstring -i, $(DH_INTERNAL_OPTIONS)))
chgrp shadow $(d)/libpam-modules/sbin/unix_chkpwd
chmod 02755 $(d)/libpam-modules/sbin/unix_chkpwd
+endif
# ideally, dh_makeshlibs could compute this from the symbols file; or we
# could drop it since anyone building against this package should have a