summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mraz <tmraz@fedoraproject.org>2015-09-04 10:35:45 +0200
committerTomas Mraz <tmraz@fedoraproject.org>2015-09-04 10:35:45 +0200
commitcaeae5bc84045df20f9e4fddcaefddde6209f6cd (patch)
tree83d2c1e5a5b5b876aee077c2555ca7cc6910b658
parentd95c7db780967f029aa30163d6cff372c0b1646e (diff)
Allow links to be used instead of w3m for documentation regeneration.
* configure.ac: If w3m is not found check for links.
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 08e45306..f33b9595 100644
--- a/configure.ac
+++ b/configure.ac
@@ -568,7 +568,12 @@ AC_PATH_PROG([BROWSER], [w3m])
if test ! -z "$BROWSER"; then
BROWSER="$BROWSER -T text/html -dump"
else
- enable_docu=no
+ AC_PATH_PROG([BROWSER], [links])
+ if test ! -z "$BROWSER"; then
+ BROWSER="$BROWSER -no-numbering -no-references -dump"
+ else
+ enable_docu=no
+ fi
fi
AC_PATH_PROG([FO2PDF], [fop])