summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew G. Morgan <morgan@kernel.org>2000-12-02 08:21:13 +0000
committerAndrew G. Morgan <morgan@kernel.org>2000-12-02 08:21:13 +0000
commitd56ee3d363e0cb0512f5e911d6d69c26917db72d (patch)
tree7afeb20c634a8d5ef58189b2fe440bfe20dd7a48
parent9fb7bba9bd09a2c18d78700739f4500d372e95a9 (diff)
Relevant BUGIDs: 124132
Purpose of commit: release Commit summary: --------------- Time to generate a release of Linux-PAM (0.73). Its almost been 12 months, and I'd really hate to actually have it hit a year exactly! [Let's hope subsequent releases will be more frequent.]
-rw-r--r--CHANGELOG6
-rw-r--r--Makefile14
-rw-r--r--doc/pam_appl.sgml2
-rw-r--r--doc/pam_modules.sgml2
4 files changed, 20 insertions, 4 deletions
diff --git a/CHANGELOG b/CHANGELOG
index b75ffb06..b77a7825 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -32,9 +32,13 @@ related bug description with the following URL:
Where you should replace XXXXX with a bug-id.
====================================================================
-0.73: please submit patches for this section with actual code/doc
+0.74: please submit patches for this section with actual code/doc
patches!
+0.73: Sat Dec 2 00:04:04 PST 2000
+
+* updated documentaion revisions and added 'make release' support
+ to the top level Makefile (Bug 124132 - agmorgan).
* documented Qmail support in pam_mail (Bug 109219 - baggins)
* add change_uid option to pam_limits, and set real uid only if
this option is present (Bug 124062 - baggins)
diff --git a/Makefile b/Makefile
index c17dc208..26e0f468 100644
--- a/Makefile
+++ b/Makefile
@@ -9,6 +9,8 @@
## configure.in not getting propagated down the tree. (AGM) [I realise
## that this may not prove possible, but at least I tried.. Sigh.]
+DISTNAME=Linux-PAM
+
ifeq ($(shell test \! -f Make.Rules || echo yes),yes)
include Make.Rules
endif
@@ -24,7 +26,7 @@ prep:
clean:
if [ ! -f Make.Rules ]; then touch Make.Rules ; fi
for i in $(THINGSTOMAKE) ; do $(MAKE) -C $$i clean ; done
- rm -f security *~ *.orig *.rej #*#
+ rm -f security *~ *.orig *.rej Make.Rules #*#
distclean: clean
rm -f Make.Rules _pam_aconf.h
@@ -60,6 +62,16 @@ remove:
rm -f $(FAKEROOT)$(INCLUDED)/_pam_aconf.h
for x in $(THINGSTOMAKE) ; do make -C $$x remove ; done
+release:
+ @if [ ! -f Make.Rules ]; then echo make Make.Rules first ; exit 1; fi
+ @if [ ! -L ../$(DISTNAME)-$(MAJOR_REL).$(MINOR_REL) ]; then \
+ echo generating ../$(DISTNAME)-$(MAJOR_REL).$(MINOR_REL) link ; \
+ ln -sf $(DISTNAME) ../$(DISTNAME)-$(MAJOR_REL).$(MINOR_REL) ; \
+ echo to ../$(DISTNAME) . ; fi
+ @diff ../$(DISTNAME)-$(MAJOR_REL).$(MINOR_REL)/Make.Rules Make.Rules
+ make distclean
+ cd .. ; tar zvfc $(DISTNAME)-$(MAJOR_REL).$(MINOR_REL).tar.gz --exclude CVS --exclude .cvsignore --exclude '.#*' $(DISTNAME)-$(MAJOR_REL).$(MINOR_REL)/*
+
## =================
ifdef LEGACY_OLD_MAKEFILE
diff --git a/doc/pam_appl.sgml b/doc/pam_appl.sgml
index d1be8c15..16c4f468 100644
--- a/doc/pam_appl.sgml
+++ b/doc/pam_appl.sgml
@@ -46,7 +46,7 @@ DAMAGE.
<title>The Linux-PAM Application Developers' Guide
<author>Andrew G. Morgan, <tt>morgan@linux.kernel.org</tt>
-<date>DRAFT v0.71 1999/11/8
+<date>DRAFT v0.73 2000/12/02
<abstract>
This manual documents what an application developer needs to know
about the <bf>Linux-PAM</bf> library. It describes how an application
diff --git a/doc/pam_modules.sgml b/doc/pam_modules.sgml
index e76e3d7a..8d313261 100644
--- a/doc/pam_modules.sgml
+++ b/doc/pam_modules.sgml
@@ -49,7 +49,7 @@ DAMAGE.
<title>The Linux-PAM Module Writers' Guide
<author>Andrew G. Morgan, <tt>morgan@linux.kernel.org</tt>
-<date>DRAFT v0.71 1999/11/8
+<date>DRAFT v0.73 2000/12/02
<abstract>
This manual documents what a programmer needs to know in order to
write a module that conforms to the <bf/Linux-PAM/ standard. It also