summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mraz <tm@t8m.info>2005-09-26 19:35:39 +0000
committerTomas Mraz <tm@t8m.info>2005-09-26 19:35:39 +0000
commite7a4b3ae9b1f401c40cfb01733193c5b8ee7f320 (patch)
tree0e558676babea6ca2b2abe93bda719858002d86d
parent2768b9a8fb819bfe5fe51a2affb2d2b8dcf1f1d5 (diff)
Relevant BUGIDs:
Purpose of commit: cleanup Commit summary: --------------- 2005-09-26 Tomas Mraz <t8m@centrum.cz> * NEWS: Add a few missing entries from CHANGELOG. * AUTHORS: Fixed entries for Toady and me * Makefile.am (M4_FILES): Fixed out of tree build. * doc/specs/Makefile.am (EXTRA_DIST): Removed lex.yy.c (spec, lex.yy.c): Fixed out of tree build. * modules/pam_userdb/README: Document try_first_pass and use_first_pass options, remove use_authtok option.
-rw-r--r--AUTHORS4
-rw-r--r--ChangeLog14
-rw-r--r--Makefile.am2
-rw-r--r--NEWS4
-rw-r--r--doc/specs/Makefile.am8
-rw-r--r--modules/pam_userdb/README11
6 files changed, 34 insertions, 9 deletions
diff --git a/AUTHORS b/AUTHORS
index 532ce0e3..daf85087 100644
--- a/AUTHORS
+++ b/AUTHORS
@@ -3,5 +3,5 @@ Original authors and current maintainers of Linux-PAM:
Andrew G. Morgan <morgan@linux.kernel.org>
Dmitry V. Levin <ldv@altlinux.org>
Thorsten Kukuk <kukuk@suse.de>
-Toady <toady@gscore.org>
-Tomas Mraz <t8m@users.sourceforge.net>
+Sebastien Tricaud <toady@gscore.org>
+Tomas Mraz <t8m@centrum.cz>
diff --git a/ChangeLog b/ChangeLog
index 0d4d29b7..1eb15d0b 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,17 @@
+2005-09-26 Tomas Mraz <t8m@centrum.cz>
+
+ * NEWS: Add a few missing entries from CHANGELOG.
+
+ * AUTHORS: Fixed entries for Toady and me
+
+ * Makefile.am (M4_FILES): Fixed out of tree build.
+ * doc/specs/Makefile.am (EXTRA_DIST): Removed lex.yy.c
+ (spec, lex.yy.c): Fixed out of tree build.
+
+ * modules/pam_userdb/README: Document try_first_pass and
+ use_first_pass options, remove use_authtok option.
+
+
2005-09-26 Dmitry V. Levin <ldv@altlinux.org>
* NEWS: Mention changes in pam_lastlog.
diff --git a/Makefile.am b/Makefile.am
index b62e26a6..78160ad7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,7 +8,7 @@ SUBDIRS = libpam libpamc libpam_misc modules po conf doc examples
CLEANFILES = *~
-M4_FILES = $(shell ls m4/*.m4)
+M4_FILES = $(shell ls $(srcdir)/m4/*.m4)
EXTRA_DIST = config.rpath mkinstalldirs pgp.keys.asc CHANGELOG \
Copyright $(M4_FILES)
diff --git a/NEWS b/NEWS
index cc54ada0..ec9a70a4 100644
--- a/NEWS
+++ b/NEWS
@@ -15,4 +15,8 @@ Release 0.99.1.0
* pam_umask: New module for setting umask from GECOS field, /etc/login.defs
or /etc/default/login
* pam_echo: New PAM module for message output
+* pam_userdb: Fix regression (crash when crypt param not specified)
+* pam_limits: Fix regression from RLIMIT_NICE support (wrong limit
+ values for other limits are applied)
+* pam_access: Support for NULL tty - matches ALL and NONE keywords
* pam_lastlog: Enable log to wtmp by default. Add "nowtmp" option.
diff --git a/doc/specs/Makefile.am b/doc/specs/Makefile.am
index 749f0ba7..dc4171c2 100644
--- a/doc/specs/Makefile.am
+++ b/doc/specs/Makefile.am
@@ -4,12 +4,12 @@
CLEANFILES = draft-morgan-pam-current.txt *~
-EXTRA_DIST = draft-morgan-pam.raw std-agent-id.raw rfc86.0.txt lex.yy.c
+EXTRA_DIST = draft-morgan-pam.raw std-agent-id.raw rfc86.0.txt
all: padout spec
spec: draft-morgan-pam.raw
- ./padout < draft-morgan-pam.raw > draft-morgan-pam-current.txt
+ ./padout < $(srcdir)/draft-morgan-pam.raw > draft-morgan-pam-current.txt
noinst_PROGRAMS = padout
@@ -19,5 +19,5 @@ padout_LDADD = @LEXLIB@
parse.c: lex.yy.c
-lex.yy.c: parse.lex
- $(LEX) parse.lex
+lex.yy.c: $(srcdir)/parse.lex
+ $(LEX) $(srcdir)/parse.lex
diff --git a/modules/pam_userdb/README b/modules/pam_userdb/README
index 8b4f6760..0d74ecb2 100644
--- a/modules/pam_userdb/README
+++ b/modules/pam_userdb/README
@@ -27,13 +27,20 @@ RECOGNIZED ARGUMENTS:
dump dump all the entries in the database to the log (eek,
don't do this by default!)
- use_authtok use the authentication token previously obtained by
+ try_first_pass use the authentication token previously obtained by
another module that did the conversation with the
application. If this token can not be obtained then
- the module will try to converse again. This option can
+ the module will try to converse. This option can
be used for stacking different modules that need to
deal with the authentication tokens.
+ use_first_pass use the authentication token previously obtained by
+ another module that did the conversation with the
+ application. If this token can not be obtained then
+ the module will fail. This option can be used for
+ stacking different modules that need to deal with
+ the authentication tokens.
+
unknown_ok do not return error when checking for a user that is
not in the database. This can be used to stack more
than one pam_userdb module that will check a