summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Černocký <marek@manet.cz>2019-09-22 08:57:36 +0200
committerTomáš Mráz <t8m@users.noreply.github.com>2019-09-23 11:09:32 +0200
commitea78d6764353c5510b235846452e6810d009b78e (patch)
tree1b654b2ec92b9e6734d129fb30b4d458a61cc7b6
parent65d6735c5949ec233df9813f734e918a93fa36cf (diff)
Fixed missing quotes in configure script
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 62b98c73..4870f131 100644
--- a/configure.ac
+++ b/configure.ac
@@ -80,7 +80,7 @@ dnl Largefile support
AC_SYS_LARGEFILE
dnl icc claims to be GCC compatible, but use other flags for warnings
-if eval "test x$GCC = xyes -a $CC != icc"; then
+if eval 'test "x$GCC" = "xyes" -a "$CC" != "icc"'; then
for flag in \
-W \
-Wall \
@@ -100,7 +100,7 @@ if eval "test x$GCC = xyes -a $CC != icc"; then
done
fi
dnl icc has special warning flags
-if eval "test x$CC = xicc"; then
+if eval 'test "x$CC" = "xicc"'; then
for flag in \
-Wall \
-Wmissing-prototypes \