summaryrefslogtreecommitdiff
path: root/Linux-PAM/modules/pam_securetty
diff options
context:
space:
mode:
authorSteve Langasek <steve.langasek@ubuntu.com>2019-01-03 16:03:16 -0800
committerSteve Langasek <steve.langasek@ubuntu.com>2019-01-03 16:05:55 -0800
commit281e859131adad49301befbc50cfc5cd282c6937 (patch)
treece45ce19af410930b834390fb8a8256bcace5006 /Linux-PAM/modules/pam_securetty
parent9a4298687784e7812c8aeef6e0e97830febbf393 (diff)
parent10ac36fdc45532acb00ec47aab28b5cc6198820f (diff)
New upstream version 0.99.9.0
Diffstat (limited to 'Linux-PAM/modules/pam_securetty')
-rw-r--r--Linux-PAM/modules/pam_securetty/Makefile.am4
-rw-r--r--Linux-PAM/modules/pam_securetty/Makefile.in7
2 files changed, 6 insertions, 5 deletions
diff --git a/Linux-PAM/modules/pam_securetty/Makefile.am b/Linux-PAM/modules/pam_securetty/Makefile.am
index ca97ef4d..dd8d9473 100644
--- a/Linux-PAM/modules/pam_securetty/Makefile.am
+++ b/Linux-PAM/modules/pam_securetty/Makefile.am
@@ -15,13 +15,13 @@ securelibdir = $(SECUREDIR)
secureconfdir = $(SCONFIGDIR)
AM_CFLAGS = -I$(top_srcdir)/libpam/include -I$(top_srcdir)/libpamc/include
-AM_LDFLAGS = -no-undefined -avoid-version -module \
- -L$(top_builddir)/libpam -lpam
+AM_LDFLAGS = -no-undefined -avoid-version -module
if HAVE_VERSIONING
AM_LDFLAGS += -Wl,--version-script=$(srcdir)/../modules.map
endif
securelib_LTLIBRARIES = pam_securetty.la
+pam_securetty_la_LIBADD = -L$(top_builddir)/libpam -lpam
if ENABLE_REGENERATE_MAN
noinst_DATA = README
diff --git a/Linux-PAM/modules/pam_securetty/Makefile.in b/Linux-PAM/modules/pam_securetty/Makefile.in
index 763404f5..9c67545e 100644
--- a/Linux-PAM/modules/pam_securetty/Makefile.in
+++ b/Linux-PAM/modules/pam_securetty/Makefile.in
@@ -64,7 +64,7 @@ am__strip_dir = `echo $$p | sed -e 's|^.*/||'`;
am__installdirs = "$(DESTDIR)$(securelibdir)" "$(DESTDIR)$(man8dir)"
securelibLTLIBRARIES_INSTALL = $(INSTALL)
LTLIBRARIES = $(securelib_LTLIBRARIES)
-pam_securetty_la_LIBADD =
+pam_securetty_la_DEPENDENCIES =
pam_securetty_la_SOURCES = pam_securetty.c
pam_securetty_la_OBJECTS = pam_securetty.lo
DEFAULT_INCLUDES = -I. -I$(top_builddir)@am__isrc@
@@ -175,6 +175,7 @@ POSUB = @POSUB@
RANLIB = @RANLIB@
SCONFIGDIR = @SCONFIGDIR@
SECUREDIR = @SECUREDIR@
+SED = @SED@
SET_MAKE = @SET_MAKE@
SHELL = @SHELL@
STRIP = @STRIP@
@@ -252,9 +253,9 @@ XMLS = README.xml pam_securetty.8.xml
securelibdir = $(SECUREDIR)
secureconfdir = $(SCONFIGDIR)
AM_CFLAGS = -I$(top_srcdir)/libpam/include -I$(top_srcdir)/libpamc/include
-AM_LDFLAGS = -no-undefined -avoid-version -module \
- -L$(top_builddir)/libpam -lpam $(am__append_1)
+AM_LDFLAGS = -no-undefined -avoid-version -module $(am__append_1)
securelib_LTLIBRARIES = pam_securetty.la
+pam_securetty_la_LIBADD = -L$(top_builddir)/libpam -lpam
@ENABLE_REGENERATE_MAN_TRUE@noinst_DATA = README
all: all-am