summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2006-08-05 08:03:11 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2006-08-05 08:03:11 +0000
commit72bcf614b2a5e5f281ca4372fa7dfccf1e6a3c43 (patch)
treeee1821fdda266c77a0f4ae403fe4358e7c45a47d /Makefile.am
parentea9255e046169e5d5b19370c9ae6292be5aacde0 (diff)
Relevant BUGIDs:
Purpose of commit: new feature Commit summary: --------------- Add xtests to allow checks for PAM functions only doable in installed system. 2006-08-05 Thorsten Kukuk <kukuk@thkukuk.de> * configure.in: Generate xtests/Makefile. * Makefile.am (SUBDIRS): Add xtests. * README: Document make check and make xtests. * xtests/Makefile.am: New. * xtests/tst-pam_dispatch1.pamd: New. * xtests/tst-pam_dispatch2.pamd: New. * xtests/tst-pam_dispatch3.pamd: New. * xtests/tst-pam_dispatch1.c: New. * xtests/tst-pam_dispatch2.c: New. * xtests/tst-pam_dispatch3.c: New.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 57250565..729589f4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,9 +5,9 @@
AUTOMAKE_OPTIONS = 1.9 gnu dist-bzip2 check-news
if STATIC_MODULES
-SUBDIRS = modules libpam libpamc libpam_misc tests po conf doc examples
+SUBDIRS = modules libpam libpamc libpam_misc tests po conf doc examples xtests
else
-SUBDIRS = libpam tests libpamc libpam_misc modules po conf doc examples
+SUBDIRS = libpam tests libpamc libpam_misc modules po conf doc examples xtests
endif
CLEANFILES = *~
@@ -32,3 +32,8 @@ releasedocs:
tar jfc Linux-PAM-$(VERSION)-docs.tar.bz2 \
Linux-PAM-$(VERSION)/doc
rm -rf Linux-PAM-$(VERSION)
+
+xtests:
+ make -C xtests xtests
+
+.PHONY: xtests