summaryrefslogtreecommitdiff
path: root/conf
diff options
context:
space:
mode:
authorChristian Göttsche <cgzones@googlemail.com>2020-10-01 10:36:41 +0200
committerDmitry V. Levin <ldv@altlinux.org>2020-10-25 08:00:00 +0000
commitb303486bf1b812dd99f48a7bbb81838d658f7e03 (patch)
treea87b5097bc6fd3824ce4c159c2244bdd3a63bd39 /conf
parentef9983f9d45d42f5d8adaf59592517092586ec73 (diff)
Add missing format function attributes and enable -Wmissing-format-attribute
Exported functions already have these attributes, add them to other functions. This enables compilers to find format specifier mismatches, like: foo_print("Hello %d", "world") * m4/warn_lang_flags.m4 (gl_WARN_ADD): Add -Wmissing-format-attribute. * conf/pam_conv1/Makefile.am (AM_CFLAGS): Add -I$(top_srcdir)/libpam/include. * conf/pam_conv1/pam_conv_y.y: Include <security/_pam_types.h>. (yyerror): Add printf format attribute. * modules/pam_pwhistory/opasswd.c (helper_log_err): Likewise. * modules/pam_rootok/pam_rootok.c (log_callback): Likewise. * modules/pam_tally/pam_tally.c (tally_log): Likewise. * modules/pam_tally2/pam_tally2.c (tally_log): Likewise. * modules/pam_unix/passverify.c (helper_log_err): Likewise.
Diffstat (limited to 'conf')
-rw-r--r--conf/pam_conv1/Makefile.am2
-rw-r--r--conf/pam_conv1/pam_conv_y.y3
2 files changed, 4 insertions, 1 deletions
diff --git a/conf/pam_conv1/Makefile.am b/conf/pam_conv1/Makefile.am
index 4c72162b..88993a20 100644
--- a/conf/pam_conv1/Makefile.am
+++ b/conf/pam_conv1/Makefile.am
@@ -8,7 +8,7 @@ EXTRA_DIST = README
AM_YFLAGS = -d
-AM_CFLAGS = $(WARN_CFLAGS)
+AM_CFLAGS = -I$(top_srcdir)/libpam/include $(WARN_CFLAGS)
pam_conv1_CFLAGS = $(AM_CFLAGS) -Wno-unused-function -Wno-sign-compare
diff --git a/conf/pam_conv1/pam_conv_y.y b/conf/pam_conv1/pam_conv_y.y
index c971abf4..66d80440 100644
--- a/conf/pam_conv1/pam_conv_y.y
+++ b/conf/pam_conv1/pam_conv_y.y
@@ -20,6 +20,8 @@
#include <ctype.h>
#include <sys/stat.h>
+#include <security/_pam_types.h>
+
extern int yylex(void);
int current_line=1;
@@ -184,6 +186,7 @@ const char *old_to_new_ctrl_flag(const char *old)
return clist[i];
}
+PAM_FORMAT((printf, 1, 2))
void yyerror(const char *format, ...)
{
va_list args;