summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDmitry V. Levin <ldv@altlinux.org>2012-01-26 22:22:59 +0000
committerDmitry V. Levin <ldv@altlinux.org>2012-01-27 00:17:54 +0000
commitfa1cf8afa8d482753900a1ac8a171b977bf40e15 (patch)
tree13517a9084ec85809d869f4062316a01df0f3e7b /configure.in
parent02680528e3b2ee9d156116540caa291cff873d74 (diff)
Make --disable-cracklib compatible with --enable-static-modules mode
* configure.in: Define HAVE_LIBCRACK when cracklib is enabled. * libpam/pam_static_modules.h (static_modules): Guard the use of _pam_cracklib_modstruct by HAVE_LIBCRACK macro.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 15ff6dc1..cba05ee3 100644
--- a/configure.in
+++ b/configure.in
@@ -363,8 +363,11 @@ if test x"$WITH_CRACKLIB" != xno ; then
else
LIBCRACK=""
fi
+if test -n "$LIBCRACK"; then
+ AC_DEFINE([HAVE_LIBCRACK], [1], [Define to 1 if you have cracklib.])
+fi
AC_SUBST(LIBCRACK)
-AM_CONDITIONAL([HAVE_LIBCRACK], [test ! -z "$LIBCRACK"])
+AM_CONDITIONAL([HAVE_LIBCRACK], [test -n "$LIBCRACK"])
dnl Look for Linux Auditing library - see documentation
AC_ARG_ENABLE([audit],