summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2007-06-20 13:54:08 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2007-06-20 13:54:08 +0000
commit2cffe6c172c372ac6ddf4c948c92373f69ed7def (patch)
tree387f17bfaa9ec2c11b2ae16595d4801e1257813c /configure.in
parentb8df468e3ad7738ae5ed8bd69fac63fcef098329 (diff)
Relevant BUGIDs: 1688777
Purpose of commit: new features Commit summary: --------------- 2007-06-20 Thorsten Kukuk <kukuk@thkukuk.de> * modules/pam_cracklib/pam_cracklib.8.xml: Document new minclass option. * modules/pam_cracklib/pam_cracklib.c: Add support for minimum character classes [#1688777]. Based on patch from Keith Schincke. * xtests/tst-pam_cracklib2.c: New, test case for minclass option. * xtests/tst-pam_cracklib2.pamd: New, PAM config file for test case. * xtests/Makefile.am: Add new testcase. * xtests/pam_cracklib.c: Fix comment what this application tests. * configure.in: Use /lib64 on x86-64, ppc64, s390x, sparc64
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index a807df7a..a3647e62 100644
--- a/configure.in
+++ b/configure.in
@@ -24,7 +24,12 @@ dnl If we use /usr as prefix, use /etc for config files
fi
if test ${libdir} = '${exec_prefix}/lib'
then
- libdir="/lib"
+ case "`uname -m`" in
+ x86_64|ppc64|s390x|sparc64)
+ libdir="/lib64" ;;
+ *)
+ libdir="/lib" ;;
+ esac
fi
if test ${sbindir} = '${exec_prefix}/sbin'
then