summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2010-06-22 14:57:44 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2010-06-22 14:57:44 +0000
commit40b7b3f621fe56a03dd21cab49507b41312d16fa (patch)
treec8f4454c4032949e0558e48f985b4fc71ba3059a /configure.in
parent6a8a52582835d5ffd1e65d3e3cd4c47d4a57c884 (diff)
Relevant BUGIDs:
Purpose of commit: bugfix Commit summary: --------------- 2010-06-22 Thorsten Kukuk <kukuk@thkukuk.de> * configure.in: Don't check for libxcrypt if no xcrypt.h exists, fix typo introduced with 1.1.1. Reported by Diego Elio "Flameeyes" Pettenò.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 0de55536..87bd5680 100644
--- a/configure.in
+++ b/configure.in
@@ -361,10 +361,14 @@ AM_CONDITIONAL([HAVE_AUDIT_TTY_STATUS],
[test "x$HAVE_AUDIT_TTY_STATUS" = xyes])
AC_CHECK_HEADERS(xcrypt.h crypt.h)
+AS_IF([test "x$ac_cv_header_xcrypt_h" = "xyes"],
+ [crypt_libs="xcrypt crypt"],
+ [crypt_libs="crypt"])
+
BACKUP_LIBS=$LIBS
-AC_SEARCH_LIBS([crypt],[xcrypt crypt], LIBCRYPT="-l$ac_lib", LIBCRYPT="")
+AC_SEARCH_LIBS([crypt],[$crypt_libs], LIBCRYPT="-l$ac_lib", LIBCRYPT="")
AC_CHECK_FUNCS(crypt_r crypt_gensalt_r)
-Libs=$BACKUP_LIBS
+LIBS=$BACKUP_LIBS
AC_SUBST(LIBCRYPT)
if test "$LIBCRYPT" = "-lxcrypt" -a "$ac_cv_header_xcrypt_h" = "yes" ; then
AC_DEFINE([HAVE_LIBXCRYPT], 1, [Define to 1 if xcrypt support should be compiled in.])