summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAndrew G. Morgan <morgan@kernel.org>2001-11-11 08:24:42 +0000
committerAndrew G. Morgan <morgan@kernel.org>2001-11-11 08:24:42 +0000
commit471c4bd0a34e8b73b9be05877e6d5bfc4a00cc82 (patch)
tree9c427eec631aaad25dbb7712a415df91d4da060b /configure.in
parent8a2221a5033467b39a850b2d081e30f9de1fe2e5 (diff)
Relevant BUGIDs: 476940
Purpose of commit: cleanup Commit summary: --------------- use autoconf to configure where the documentation should go.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 91354aed..0227c412 100644
--- a/configure.in
+++ b/configure.in
@@ -104,6 +104,16 @@ AC_ARG_ENABLE(includedir,
INCLUDEDIR=$enableval, INCLUDEDIR=/usr/include)
AC_SUBST(INCLUDEDIR)
+AC_ARG_ENABLE(docdir,
+[ --enable-docdir=<path to store documentation in - /usr/share/doc/pam>],
+ DOCDIR=$enableval, DOCDIR=/usr/share/doc/pam)
+AC_SUBST(DOCDIR)
+
+AC_ARG_ENABLE(mandir,
+[ --enable-mandir=<path to store manuals in - /usr/share/man>],
+ MANDIR=$enableval, MANDIR=/usr/share/man)
+AC_SUBST(MANDIR)
+
AC_ARG_ENABLE(pamlocking,
[ --enable-pamlocking configure libpam to observe a global authentication lock],
WITH_PAMLOCKING=yes ; AC_DEFINE(PAM_LOCKING) , WITH_PAMLOCKING=no)