summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDmitry V. Levin <ldv@altlinux.org>2014-12-09 21:47:40 +0000
committerDmitry V. Levin <ldv@altlinux.org>2014-12-10 00:52:17 +0000
commit9d1545efee73ec834b051c50a1bc0d2a63d8765b (patch)
tree4ee14ac07912f52dadd163527f5e54cba91b5373 /configure.in
parent8da3f3c38e075498a24fb9db80ae9862bda7154d (diff)
build: extend cross compiling check to cover CPPFLAGS (ticket #21)
Use BUILD_CPPFLAGS variable to override CPPFLAGS where necessary in case of cross compiling, in addition to CC_FOR_BUILD, BUILD_CFLAGS, and BUILD_LDFLAGS variables introduced earlier to override CC, CFLAGS, and LDFLAGS, respectively. * configure.in (BUILD_CPPFLAGS): Define. * doc/specs/Makefile.am (CPPFLAGS): Define to @BUILD_CPPFLAGS@.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 2597802f..6797e2fe 100644
--- a/configure.in
+++ b/configure.in
@@ -144,6 +144,15 @@ AC_MSG_CHECKING([for CC_FOR_BUILD])
AC_MSG_RESULT([$CC_FOR_BUILD])
AC_SUBST(CC_FOR_BUILD)
+if test "x${BUILD_CPPFLAGS+set}" != "xset" ; then
+ if test "x$cross_compiling" = "xyes" ; then
+ BUILD_CPPFLAGS=
+ else
+ BUILD_CPPFLAGS=${CPPFLAGS}
+ fi
+fi
+AC_SUBST(BUILD_CPPFLAGS)
+
if test "x${BUILD_CFLAGS+set}" != "xset" ; then
if test "x$cross_compiling" = "xyes" ; then
BUILD_CFLAGS=