summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAndrew G. Morgan <morgan@kernel.org>2000-12-07 22:30:52 +0000
committerAndrew G. Morgan <morgan@kernel.org>2000-12-07 22:30:52 +0000
commitbc78f93093b79843dc69101e4a2f5e846462b525 (patch)
treed73cd0d41ed722e0ab27ee4a8468d6067149e577 /configure.in
parent22e6ce5f33d486d0df8213e9f94254afd5ea19e0 (diff)
Relevant BUGIDs: 124923
Purpose of commit: cleanup Commit summary: --------------- Remove the -Wtraditional flag from the GCC options. It causes strange and annoying spam. Also reordered the progs verses argument parsing stuff to avoid a warning from autoconf (back to one strange warning again).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 10 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index 2c98dbcb..5ec46150 100644
--- a/configure.in
+++ b/configure.in
@@ -45,6 +45,15 @@ dnl ### Would need to distribute GNU's config.guess and config.sub
dnl AC_PROG_INSTALL
INSTALL=/usr/bin/install ; AC_SUBST(INSTALL)
+dnl Checks for programs.
+AC_PROG_CC
+AC_PROG_CXX
+AC_PROG_YACC
+AC_PROG_LEX
+dnl AC_PROG_INSTALL
+AC_PROG_LN_S
+AC_PROG_MAKE_SET
+
dnl
dnl options and defaults
dnl
@@ -144,15 +153,6 @@ pam_mail_spool="\"/var/spool/mail\"")
fi
AC_DEFINE_UNQUOTED(PAM_PATH_MAILDIR, $pam_mail_spool)
-dnl Checks for programs.
-AC_PROG_CXX
-AC_PROG_YACC
-AC_PROG_LEX
-AC_PROG_CC
-dnl AC_PROG_INSTALL
-AC_PROG_LN_S
-AC_PROG_MAKE_SET
-
dnl Checks for libraries.
AC_CHECK_LIB(c, __libc_sched_setscheduler, PAM_NEEDS_LIBC=, PAM_NEEDS_LIBC=-lc)
AC_SUBST(PAM_NEEDS_LIBC)
@@ -252,7 +252,7 @@ dnl this should be done selectively.
GCC_WARNINGS="-Wall -Wwrite-strings \
-Wpointer-arith -Wcast-qual -Wcast-align \
- -Wtraditional -Wstrict-prototypes -Wmissing-prototypes \
+ -Wstrict-prototypes -Wmissing-prototypes \
-Wnested-externs -Winline -Wshadow"
if test "$GCC" = yes; then