summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAndrew G. Morgan <morgan@kernel.org>2001-02-10 07:17:52 +0000
committerAndrew G. Morgan <morgan@kernel.org>2001-02-10 07:17:52 +0000
commitd66ecd8caf597bcc794f9b9b1716a4f4ab4cfed2 (patch)
tree6e4ba1066ad59fbc3e4ae1ef099e74e65de00b8e /configure.in
parent63b197ed633d413f976c644b2693ed084bcfee6e (diff)
Relevant BUGIDs: 131783
Purpose of commit: bugfix Commit summary: --------------- static library and debugging library support fixed - post autoconf stuff.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index a1d501dc..cc93723e 100644
--- a/configure.in
+++ b/configure.in
@@ -265,7 +265,9 @@ if test "$GCC" = yes; then
LD=ld
LD_D="gcc -shared -Xlinker -x"
LD_L="$LD -x -shared"
+ RANLIB=ranlib
STRIP=strip
+ CC_STATIC="-Xlinker -export-dynamic"
else
###
### Non-gcc needs attention on per-OS basis
@@ -277,7 +279,9 @@ else
LD=ld
LD_D="cc -z text -G -R."
LD_L="$LD_D"
+ RANLIB=ranlib
STRIP=strip
+ CC_STATIC=
fi
AC_SUBST(OS_CFLAGS)
@@ -286,7 +290,9 @@ AC_SUBST(PIC)
AC_SUBST(LD)
AC_SUBST(LD_D)
AC_SUBST(LD_L)
+AC_SUBST(RANLIB)
AC_SUBST(STRIP)
+AC_SUBST(CC_STATIC)
dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_BIGENDIAN