summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAndrew G. Morgan <morgan@kernel.org>2001-04-15 06:42:38 +0000
committerAndrew G. Morgan <morgan@kernel.org>2001-04-15 06:42:38 +0000
commitb9c88b6c2d291ddc8011c4b3d18e28108cb5b937 (patch)
tree630249a6e661ba25bf7155d32afe02f7423020cb /configure.in
parent7af49ccf1eceae79ce796f18d5f19be4892d2746 (diff)
Relevant BUGIDs: 415412
Purpose of commit: support Commit summary: --------------- Some solaris support for gcc options that appear to work.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 11 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 81e92969..3e7287ff 100644
--- a/configure.in
+++ b/configure.in
@@ -265,9 +265,17 @@ GCC_WARNINGS="-Wall -Wwrite-strings \
-Wnested-externs -Winline -Wshadow"
if test "$GCC" = yes; then
-###
-### Non-Linux needs attention on per-OS basis
- OS_CFLAGS="-ansi -D_POSIX_SOURCE -pedantic"
+ OS_CFLAGS=""
+### May need per-OS attention
+### Example: -D_POSIX_SOURCE: needed on Linux but harms Solaris.
+ case $OS in
+ linux)
+ OS_CFLAGS="-ansi -D_POSIX_SOURCE -pedantic"
+ ;;
+ sunos)
+ OS_CFLAGS="-ansi -pedantic"
+ ;;
+ esac
WARNINGS="$GCC_WARNINGS"
PIC="-fPIC"
#can/should we use LD=gcc ???