summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAndrew G. Morgan <morgan@kernel.org>2002-05-29 06:35:46 +0000
committerAndrew G. Morgan <morgan@kernel.org>2002-05-29 06:35:46 +0000
commite509c5af6f70eb3cfd846004b82caaca24fd4a3b (patch)
treefe9859716e1120d88c1d3b6bf24aa1617c138332 /configure.in
parent62f3574062ed05e9afd512028994bd17639c0b2f (diff)
Relevant BUGIDs: 491466
Purpose of commit: cleanup Commit summary: --------------- These were all suggestions from the OS X patch provided by Luke Howard. There is another proposed patch for OS X support which promises to be a little cleaner with the heavy stuff, so I am committing these simple changes now, with the intention of moving to the other patch for the big stuff (see 534205).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index f4048fef..69087a03 100644
--- a/configure.in
+++ b/configure.in
@@ -222,6 +222,12 @@ AC_SUBST(HAVE_LIBNSL)
AC_CHECK_LIB(pwdb, pwdb_db_name, HAVE_LIBPWDB=yes ; AC_DEFINE(HAVE_LIBPWDB),
HAVE_LIBPWDB=no)
AC_SUBST(HAVE_LIBPWDB)
+AC_CHECK_LIB(fl, yywrap, HAVE_LIBFLEX=yes ; AC_DEFINE(HAVE_LIBFLEX),
+ HAVE_LIBFLEX=no)
+AC_SUBST(HAVE_LIBFLEX)
+AC_CHECK_LIB(l, yywrap, HAVE_LIBLEX=yes ; AC_DEFINE(HAVE_LIBLEX),
+ HAVE_LIBLEX=no)
+AC_SUBST(HAVE_LIBLEX)
dnl Checks for header files.
AC_HEADER_DIRENT
@@ -337,6 +343,11 @@ else
### Non-gcc needs attention on per-OS basis
###
case "$OS" in
+ darwin)
+# add some stuff here (see sourceforge bug 534205)
+# DOCDIR=/System/Documentation/Administration/Libraries/PAM
+# MANDIR=/usr/share/man
+ ;;
solaris)
### Support for Solaris-C
OS_CFLAGS=""