summaryrefslogtreecommitdiff
path: root/debian/patches-applied/007_modules_pam_unix
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2014-01-14 09:30:06 +0000
committerSteve Langasek <vorlon@debian.org>2019-01-08 22:11:52 -0800
commit76063db40810118bf431971dade8871633d06864 (patch)
treebf04fce4c2288ebf24e3465697b25b40a267172e /debian/patches-applied/007_modules_pam_unix
parente4b6c30426509601fddd1611f7db99b076626c17 (diff)
Another round of patch refreshing
Diffstat (limited to 'debian/patches-applied/007_modules_pam_unix')
-rw-r--r--debian/patches-applied/007_modules_pam_unix136
1 files changed, 68 insertions, 68 deletions
diff --git a/debian/patches-applied/007_modules_pam_unix b/debian/patches-applied/007_modules_pam_unix
index 95d2e354..5dae4064 100644
--- a/debian/patches-applied/007_modules_pam_unix
+++ b/debian/patches-applied/007_modules_pam_unix
@@ -2,7 +2,7 @@ Index: pam.debian/modules/pam_unix/pam_unix_passwd.c
===================================================================
--- pam.debian.orig/modules/pam_unix/pam_unix_passwd.c
+++ pam.debian/modules/pam_unix/pam_unix_passwd.c
-@@ -97,6 +97,9 @@
+@@ -102,6 +102,9 @@
# endif /* GNU libc 2.1 */
#endif
@@ -12,7 +12,7 @@ Index: pam.debian/modules/pam_unix/pam_unix_passwd.c
/*
How it works:
Gets in username (has to be done) from the calling program
-@@ -513,6 +516,11 @@
+@@ -521,6 +524,11 @@
return retval;
}
}
@@ -24,7 +24,7 @@ Index: pam.debian/modules/pam_unix/pam_unix_passwd.c
}
if (remark) {
_make_remark(pamh, ctrl, PAM_ERROR_MSG, remark);
-@@ -529,7 +537,7 @@
+@@ -536,7 +544,7 @@
int retval;
int remember = -1;
int rounds = -1;
@@ -37,7 +37,7 @@ Index: pam.debian/modules/pam_unix/support.h
===================================================================
--- pam.debian.orig/modules/pam_unix/support.h
+++ pam.debian/modules/pam_unix/support.h
-@@ -90,8 +90,9 @@
+@@ -97,8 +97,9 @@
password hash algorithms */
#define UNIX_BLOWFISH_PASS 26 /* new password hashes will use blowfish */
#define UNIX_MIN_PASS_LEN 27 /* min length for password */
@@ -48,67 +48,67 @@ Index: pam.debian/modules/pam_unix/support.h
#define UNIX_DES_CRYPT(ctrl) (off(UNIX_MD5_PASS,ctrl)&&off(UNIX_BIGCRYPT,ctrl)&&off(UNIX_SHA256_PASS,ctrl)&&off(UNIX_SHA512_PASS,ctrl)&&off(UNIX_BLOWFISH_PASS,ctrl))
-@@ -100,34 +101,35 @@
+@@ -107,34 +108,35 @@
/* symbol token name ctrl mask ctrl *
* ----------------------- ------------------- --------------------- -------- */
--/* UNIX__OLD_PASSWD */ {NULL, _ALL_ON_, 01},
--/* UNIX__VERIFY_PASSWD */ {NULL, _ALL_ON_, 02},
--/* UNIX__IAMROOT */ {NULL, _ALL_ON_, 04},
--/* UNIX_AUDIT */ {"audit", _ALL_ON_, 010},
--/* UNIX_USE_FIRST_PASS */ {"use_first_pass", _ALL_ON_^(060), 020},
--/* UNIX_TRY_FIRST_PASS */ {"try_first_pass", _ALL_ON_^(060), 040},
--/* UNIX_NOT_SET_PASS */ {"not_set_pass", _ALL_ON_, 0100},
--/* UNIX__PRELIM */ {NULL, _ALL_ON_^(0600), 0200},
--/* UNIX__UPDATE */ {NULL, _ALL_ON_^(0600), 0400},
--/* UNIX__NONULL */ {NULL, _ALL_ON_, 01000},
--/* UNIX__QUIET */ {NULL, _ALL_ON_, 02000},
--/* UNIX_USE_AUTHTOK */ {"use_authtok", _ALL_ON_, 04000},
--/* UNIX_SHADOW */ {"shadow", _ALL_ON_, 010000},
--/* UNIX_MD5_PASS */ {"md5", _ALL_ON_^(0260420000), 020000},
--/* UNIX__NULLOK */ {"nullok", _ALL_ON_^(01000), 0},
--/* UNIX_DEBUG */ {"debug", _ALL_ON_, 040000},
--/* UNIX_NODELAY */ {"nodelay", _ALL_ON_, 0100000},
--/* UNIX_NIS */ {"nis", _ALL_ON_, 0200000},
--/* UNIX_BIGCRYPT */ {"bigcrypt", _ALL_ON_^(0260420000), 0400000},
--/* UNIX_LIKE_AUTH */ {"likeauth", _ALL_ON_, 01000000},
--/* UNIX_REMEMBER_PASSWD */ {"remember=", _ALL_ON_, 02000000},
--/* UNIX_NOREAP */ {"noreap", _ALL_ON_, 04000000},
--/* UNIX_BROKEN_SHADOW */ {"broken_shadow", _ALL_ON_, 010000000},
--/* UNIX_SHA256_PASS */ {"sha256", _ALL_ON_^(0260420000), 020000000},
--/* UNIX_SHA512_PASS */ {"sha512", _ALL_ON_^(0260420000), 040000000},
--/* UNIX_ALGO_ROUNDS */ {"rounds=", _ALL_ON_, 0100000000},
--/* UNIX_BLOWFISH_PASS */ {"blowfish", _ALL_ON_^(0260420000), 0200000000},
--/* UNIX_MIN_PASS_LEN */ {"minlen=", _ALL_ON_, 0400000000},
-+/* UNIX__OLD_PASSWD */ {NULL, _ALL_ON_, 0x1},
-+/* UNIX__VERIFY_PASSWD */ {NULL, _ALL_ON_, 0x2},
-+/* UNIX__IAMROOT */ {NULL, _ALL_ON_, 0x4},
-+/* UNIX_AUDIT */ {"audit", _ALL_ON_, 0x8},
-+/* UNIX_USE_FIRST_PASS */ {"use_first_pass", _ALL_ON_^(0x30), 0x10},
-+/* UNIX_TRY_FIRST_PASS */ {"try_first_pass", _ALL_ON_^(0x30), 0x20},
-+/* UNIX_NOT_SET_PASS */ {"not_set_pass", _ALL_ON_, 0x40},
-+/* UNIX__PRELIM */ {NULL, _ALL_ON_^(0x180), 0x80},
-+/* UNIX__UPDATE */ {NULL, _ALL_ON_^(0x180), 0x100},
-+/* UNIX__NONULL */ {NULL, _ALL_ON_, 0x200},
-+/* UNIX__QUIET */ {NULL, _ALL_ON_, 0x400},
-+/* UNIX_USE_AUTHTOK */ {"use_authtok", _ALL_ON_, 0x800},
-+/* UNIX_SHADOW */ {"shadow", _ALL_ON_, 0x1000},
-+/* UNIX_MD5_PASS */ {"md5", _ALL_ON_^(0x2C22000), 0x2000},
-+/* UNIX__NULLOK */ {"nullok", _ALL_ON_^(0x200), 0},
-+/* UNIX_DEBUG */ {"debug", _ALL_ON_, 0x4000},
-+/* UNIX_NODELAY */ {"nodelay", _ALL_ON_, 0x8000},
-+/* UNIX_NIS */ {"nis", _ALL_ON_, 0x10000},
-+/* UNIX_BIGCRYPT */ {"bigcrypt", _ALL_ON_^(0x2C22000), 0x20000},
-+/* UNIX_LIKE_AUTH */ {"likeauth", _ALL_ON_, 0x40000},
-+/* UNIX_REMEMBER_PASSWD */ {"remember=", _ALL_ON_, 0x80000},
-+/* UNIX_NOREAP */ {"noreap", _ALL_ON_, 0x100000},
-+/* UNIX_BROKEN_SHADOW */ {"broken_shadow", _ALL_ON_, 0x200000},
-+/* UNIX_SHA256_PASS */ {"sha256", _ALL_ON_^(0x2C22000), 0x400000},
-+/* UNIX_SHA512_PASS */ {"sha512", _ALL_ON_^(0x2C22000), 0x800000},
-+/* UNIX_ALGO_ROUNDS */ {"rounds=", _ALL_ON_, 0x1000000},
-+/* UNIX_BLOWFISH_PASS */ {"blowfish", _ALL_ON_^(0x2C22000),0x2000000},
-+/* UNIX_MIN_PASS_LEN */ {"minlen=", _ALL_ON_, 0x4000000},
-+/* UNIX_OBSCURE_CHECKS */ {"obscure", _ALL_ON_, 0x8000000},
+-/* UNIX__OLD_PASSWD */ {NULL, _ALL_ON_, 01, 0},
+-/* UNIX__VERIFY_PASSWD */ {NULL, _ALL_ON_, 02, 0},
+-/* UNIX__IAMROOT */ {NULL, _ALL_ON_, 04, 0},
+-/* UNIX_AUDIT */ {"audit", _ALL_ON_, 010, 0},
+-/* UNIX_USE_FIRST_PASS */ {"use_first_pass", _ALL_ON_^(060), 020, 0},
+-/* UNIX_TRY_FIRST_PASS */ {"try_first_pass", _ALL_ON_^(060), 040, 0},
+-/* UNIX_NOT_SET_PASS */ {"not_set_pass", _ALL_ON_, 0100, 0},
+-/* UNIX__PRELIM */ {NULL, _ALL_ON_^(0600), 0200, 0},
+-/* UNIX__UPDATE */ {NULL, _ALL_ON_^(0600), 0400, 0},
+-/* UNIX__NONULL */ {NULL, _ALL_ON_, 01000, 0},
+-/* UNIX__QUIET */ {NULL, _ALL_ON_, 02000, 0},
+-/* UNIX_USE_AUTHTOK */ {"use_authtok", _ALL_ON_, 04000, 0},
+-/* UNIX_SHADOW */ {"shadow", _ALL_ON_, 010000, 0},
+-/* UNIX_MD5_PASS */ {"md5", _ALL_ON_^(0260420000), 020000, 1},
+-/* UNIX__NULLOK */ {"nullok", _ALL_ON_^(01000), 0, 0},
+-/* UNIX_DEBUG */ {"debug", _ALL_ON_, 040000, 0},
+-/* UNIX_NODELAY */ {"nodelay", _ALL_ON_, 0100000, 0},
+-/* UNIX_NIS */ {"nis", _ALL_ON_, 0200000, 0},
+-/* UNIX_BIGCRYPT */ {"bigcrypt", _ALL_ON_^(0260420000), 0400000, 1},
+-/* UNIX_LIKE_AUTH */ {"likeauth", _ALL_ON_, 01000000, 0},
+-/* UNIX_REMEMBER_PASSWD */ {"remember=", _ALL_ON_, 02000000, 0},
+-/* UNIX_NOREAP */ {"noreap", _ALL_ON_, 04000000, 0},
+-/* UNIX_BROKEN_SHADOW */ {"broken_shadow", _ALL_ON_, 010000000, 0},
+-/* UNIX_SHA256_PASS */ {"sha256", _ALL_ON_^(0260420000), 020000000, 1},
+-/* UNIX_SHA512_PASS */ {"sha512", _ALL_ON_^(0260420000), 040000000, 1},
+-/* UNIX_ALGO_ROUNDS */ {"rounds=", _ALL_ON_, 0100000000, 0},
+-/* UNIX_BLOWFISH_PASS */ {"blowfish", _ALL_ON_^(0260420000), 0200000000, 1},
+-/* UNIX_MIN_PASS_LEN */ {"minlen=", _ALL_ON_, 0400000000, 0},
++/* UNIX__OLD_PASSWD */ {NULL, _ALL_ON_, 0x1, 0},
++/* UNIX__VERIFY_PASSWD */ {NULL, _ALL_ON_, 0x2, 0},
++/* UNIX__IAMROOT */ {NULL, _ALL_ON_, 0x4, 0},
++/* UNIX_AUDIT */ {"audit", _ALL_ON_, 0x8, 0},
++/* UNIX_USE_FIRST_PASS */ {"use_first_pass", _ALL_ON_^(0x30), 0x10, 0},
++/* UNIX_TRY_FIRST_PASS */ {"try_first_pass", _ALL_ON_^(0x30), 0x20, 0},
++/* UNIX_NOT_SET_PASS */ {"not_set_pass", _ALL_ON_, 0x40, 0},
++/* UNIX__PRELIM */ {NULL, _ALL_ON_^(0x180), 0x80, 0},
++/* UNIX__UPDATE */ {NULL, _ALL_ON_^(0x180), 0x100, 0},
++/* UNIX__NONULL */ {NULL, _ALL_ON_, 0x200, 0},
++/* UNIX__QUIET */ {NULL, _ALL_ON_, 0x400, 0},
++/* UNIX_USE_AUTHTOK */ {"use_authtok", _ALL_ON_, 0x800, 0},
++/* UNIX_SHADOW */ {"shadow", _ALL_ON_, 0x1000, 0},
++/* UNIX_MD5_PASS */ {"md5", _ALL_ON_^(0x2C22000), 0x2000, 1},
++/* UNIX__NULLOK */ {"nullok", _ALL_ON_^(0x200), 0, 0},
++/* UNIX_DEBUG */ {"debug", _ALL_ON_, 0x4000, 0},
++/* UNIX_NODELAY */ {"nodelay", _ALL_ON_, 0x8000, 0},
++/* UNIX_NIS */ {"nis", _ALL_ON_, 0x10000, 0},
++/* UNIX_BIGCRYPT */ {"bigcrypt", _ALL_ON_^(0x2C22000), 0x20000, 1},
++/* UNIX_LIKE_AUTH */ {"likeauth", _ALL_ON_, 0x40000, 0},
++/* UNIX_REMEMBER_PASSWD */ {"remember=", _ALL_ON_, 0x80000, 0},
++/* UNIX_NOREAP */ {"noreap", _ALL_ON_, 0x100000, 0},
++/* UNIX_BROKEN_SHADOW */ {"broken_shadow", _ALL_ON_, 0x200000, 0},
++/* UNIX_SHA256_PASS */ {"sha256", _ALL_ON_^(0x2C22000), 0x400000, 1},
++/* UNIX_SHA512_PASS */ {"sha512", _ALL_ON_^(0x2C22000), 0x800000, 1},
++/* UNIX_ALGO_ROUNDS */ {"rounds=", _ALL_ON_, 0x1000000, 0},
++/* UNIX_BLOWFISH_PASS */ {"blowfish", _ALL_ON_^(0x2C22000),0x2000000, 1},
++/* UNIX_MIN_PASS_LEN */ {"minlen=", _ALL_ON_, 0x4000000, 0},
++/* UNIX_OBSCURE_CHECKS */ {"obscure", _ALL_ON_, 0x8000000, 0},
};
#define UNIX_DEFAULTS (unix_args[UNIX__NONULL].flag)
@@ -116,7 +116,7 @@ Index: pam.debian/modules/pam_unix/pam_unix.8.xml
===================================================================
--- pam.debian.orig/modules/pam_unix/pam_unix.8.xml
+++ pam.debian/modules/pam_unix/pam_unix.8.xml
-@@ -333,8 +333,81 @@
+@@ -337,8 +337,81 @@
<listitem>
<para>
Set a minimum password length of <replaceable>n</replaceable>
@@ -407,20 +407,20 @@ Index: pam.debian/modules/pam_unix/Makefile.am
===================================================================
--- pam.debian.orig/modules/pam_unix/Makefile.am
+++ pam.debian/modules/pam_unix/Makefile.am
-@@ -42,7 +42,7 @@
+@@ -43,7 +43,7 @@
pam_unix_la_SOURCES = bigcrypt.c pam_unix_acct.c \
pam_unix_auth.c pam_unix_passwd.c pam_unix_sess.c support.c \
- passverify.c yppasswd_xdr.c md5_good.c md5_broken.c
+ passverify.c yppasswd_xdr.c md5_good.c md5_broken.c obscure.c
-
- bigcrypt_SOURCES = bigcrypt.c bigcrypt_main.c
- bigcrypt_CFLAGS = $(AM_CFLAGS)
+ if STATIC_MODULES
+ pam_unix_la_SOURCES += pam_unix_static.c
+ endif
Index: pam.debian/modules/pam_unix/pam_unix.8
===================================================================
--- pam.debian.orig/modules/pam_unix/pam_unix.8
+++ pam.debian/modules/pam_unix/pam_unix.8
-@@ -178,7 +178,38 @@
+@@ -183,7 +183,38 @@
.RS 4
Set a minimum password length of
\fIn\fR