summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2009-08-25 13:45:37 -0700
committerSteve Langasek <vorlon@debian.org>2019-01-08 21:25:57 -0800
commit9e634f29ea8bfdb719a57da61bd04420ab1e5202 (patch)
tree0540a16e4c302a226cab3275bd872c793e6c7d98 /debian/rules
parentec62cb7dc2888a36436031294585f9d367a09b28 (diff)
Build with LDFLAGS=-Wl,-z,defs to guard against the possibility of
any undefined symbols (due to typos or otherwise) at build time. Closes: #10231.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules3
1 files changed, 2 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 389e2fb9..6a4b1268 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,6 +5,7 @@
# architecture-dependant package, as well as an architecture-independant
# package.
+LDFLAGS := -Wl,-z,defs
CFLAGS := -g -D_GNU_SOURCE -D_REENTRANT -fPIC
ifeq (,$(findstring noopt, ${DEB_BUILD_OPTIONS}))
@@ -38,7 +39,7 @@ build-stamp:
dh_testdir
# Compile everything else
- $(MAKE) -C $(BUILD_TREE) CFLAGS="$(CFLAGS)"
+ $(MAKE) -C $(BUILD_TREE) CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)"
pod2man --section 8 --release="Debian GNU/Linux" $(dl)/pam_getenv >$(dl)/pam_getenv.8