summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2011-09-25 15:10:54 -0700
committerSteve Langasek <vorlon@debian.org>2019-01-08 22:11:46 -0800
commit616670d6ecb69282a2076417afe65ae7d97faf13 (patch)
treee1ec54f158bc50b5669011804a98369b0a66c6a2 /debian/rules
parent92b37e4e4efc17c68c81ed8bae4a2614133fc906 (diff)
Make sure shared library links are also installed to the multiarch
directory, not just the .a files; otherwise the static libs get found first by the linker. Thanks to Russ Allbery for catching this. Closes: #642952.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index f24686c2..e1a566d2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -46,7 +46,7 @@ override_dh_installman:
# dh_link doesn't do wildcards, so we can't auto-link to the right per-arch
# directory
override_dh_link:
- sed -e"s,^/lib,/lib/$(DEB_HOST_MULTIARCH)," $(d)/libpam0g-dev.links.in > $(d)/libpam0g-dev.links
+ sed -e"s/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g" $(d)/libpam0g-dev.links.in > $(d)/libpam0g-dev.links
dh_link
# using perms that differ from upstream (sgid instead of suid) /and/ that