summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2014-04-07 17:49:33 -0700
committerSteve Langasek <vorlon@debian.org>2019-01-08 22:11:53 -0800
commite9fbae70fbfb5ccdeef59af2c5b1587e921ab01e (patch)
tree2982ae811ff66605cfc74ab05938b499e16b7e27 /debian/rules
parent626c61d5de60d03e06fa214a38e1381e757b479f (diff)
debian/rules: On hurd, link libpam explicitly with -lpthread since glibc
will not dynamically switch between the libc stubs and the libpthread implementations on this architecture. Thanks to Samuel Thibault for the patch. Closes: #743891.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules3
1 files changed, 3 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 3260ed99..1bb42123 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,6 +3,9 @@
DEB_LDFLAGS_MAINT_APPEND := -Wl,-z,defs
DEB_CFLAGS_MAINT_APPEND := $(shell getconf LFS_CFLAGS)
export DEB_LDFLAGS_MAINT_APPEND DEB_CFLAGS_MAINT_APPEND
+ifeq ($(shell dpkg-architecture -qDEB_BUILD_ARCH_OS),hurd)
+DEB_LDFLAGS_MAINT_APPEND += -lpthread
+endif
DEB_HOST_MULTIARCH := $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)