summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2011-09-24 01:23:19 +0000
committerSteve Langasek <vorlon@debian.org>2019-01-08 22:11:46 -0800
commit6abeb002287effb250599f3923dbd6913e3f8e38 (patch)
tree68f779d9074e5d6eff9826a5d2bda35a298823ba /debian/rules
parent8a0443f89b618211154ef8473d1bf42a2ebce37d (diff)
Build-depend on debhelper 8.9.4 and bump debian/compat to 9 for
dpkg-buildflags integration, and drop manual setting of -g -O options in CFLAGS now that we can let dh do it for us
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules14
1 files changed, 4 insertions, 10 deletions
diff --git a/debian/rules b/debian/rules
index 2c11444c..5784bd1f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,13 +1,8 @@
#!/usr/bin/make -f
-LDFLAGS := -Wl,-z,defs
-CFLAGS := -g $(shell getconf LFS_CFLAGS)
-
-ifeq (,$(findstring noopt, ${DEB_BUILD_OPTIONS}))
-CFLAGS += -O2
-else
-CFLAGS += -O0
-endif
+DEB_LDFLAGS_MAINT_APPEND := -Wl,-z,defs
+DEB_CFLAGS_MAINT_APPEND := $(shell getconf LFS_CFLAGS)
+export DEB_LDFLAGS_MAINT_APPEND DEB_CFLAGS_MAINT_APPEND
DEB_HOST_MULTIARCH := $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
@@ -25,8 +20,7 @@ dl = $(d)/local
override_dh_auto_configure:
dh_auto_configure -- --enable-static --enable-shared \
--libdir=/lib/$(DEB_HOST_MULTIARCH) --sbindir=/sbin \
- --enable-isadir=/lib/security --disable-audit \
- CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)"
+ --enable-isadir=/lib/security --disable-audit
# make sure the SAG, MWG, ADG are readable with a browser.
override_dh_compress: