summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2009-09-03 02:24:40 -0700
committerSteve Langasek <vorlon@debian.org>2019-01-08 21:26:00 -0800
commit9c0389a6f68dc743d2b9a796f432074113780ed9 (patch)
treee5d36bea1c8834278754858b16db7e30f464aac6 /debian
parent6cb8f4c1ab8ef36732aac0b36af5237e8847ea86 (diff)
consolidate, comment the override targets
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules16
1 files changed, 11 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index c115d852..4c601548 100755
--- a/debian/rules
+++ b/debian/rules
@@ -22,31 +22,37 @@ dl = $(d)/local
%:
dh $@ --with quilt
-override_dh_auto_build:
- # Compile everything else
- dh_auto_build
- pod2man --section 8 --release="Debian GNU/Linux" $(dl)/pam_getenv >$(dl)/pam_getenv.8
-
override_dh_auto_configure:
dh_auto_configure -- --enable-static --enable-shared \
--libdir=/lib --sbindir=/sbin --disable-audit \
CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)"
+# make sure the SAG, MWG, ADG are readable with a browser.
override_dh_compress:
dh_compress -Xhtml
+# .install files don't have "except for" handling, so we need to exclude
+# our module that doesn't match right here
override_dh_install:
dh_install -plibpam-modules -Xpam_cracklib
dh_install -Nlibpam-modules
+# again, excluding files by hand; also, build our local manpage for pam_getenv
+# from the XML
override_dh_installman:
+ pod2man --section 8 --release="Debian GNU/Linux" $(dl)/pam_getenv >$(dl)/pam_getenv.8
dh_installman
rm -f $(d)/libpam-modules/usr/share/man/man5/pam.conf.5
+# using perms that differ from upstream (sgid instead of suid) /and/ that
+# dh_fixperms doesn't want
override_dh_fixperms:
dh_fixperms
chgrp shadow $(d)/libpam-modules/sbin/unix_chkpwd
chmod 02755 $(d)/libpam-modules/sbin/unix_chkpwd
+# ideally, dh_makeshlibs could compute this from the symbols file; or we
+# could drop it since anyone building against this package should have a
+# dpkg-shlibdeps available that knows about symbols files?
override_dh_makeshlibs:
dh_makeshlibs -V "libpam0g (>= 1.1.0)"