summaryrefslogtreecommitdiff
path: root/doc/Makefile
diff options
context:
space:
mode:
authorAndrew G. Morgan <morgan@kernel.org>2001-01-22 08:03:01 +0000
committerAndrew G. Morgan <morgan@kernel.org>2001-01-22 08:03:01 +0000
commitb89c0d4ccae2f48cfa1e28423e2fe86e1d435ec5 (patch)
tree75b9298ff2838f6e433afc58f35e9a598c608745 /doc/Makefile
parentec6d77b384ea083cb69a1d6df91c875eee2d1228 (diff)
Relevant BUGIDs: 129644
Purpose of commit: start next release Commit summary: --------------- I've bumped the version number, and added some Makefile code for helping me make documentation releases.
Diffstat (limited to 'doc/Makefile')
-rw-r--r--doc/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/doc/Makefile b/doc/Makefile
index 21ae3de2..62702cc8 100644
--- a/doc/Makefile
+++ b/doc/Makefile
@@ -126,6 +126,13 @@ endif
install -m 644 $$file $(FAKEROOT)$(MANDIR)/man8 ; \
done
+spec:
+ cd specs/formatter && make
+ specs/formatter/padout < specs/draft-morgan-pam.raw > specs/draft-morgan-pam-current.txt
+
+releasedocs: all spec
+ tar zvfc Linux-PAM-$(MAJOR_REL).$(MINOR_REL)-docs.tar.gz --exclude CVS html ps txts specs/draft-morgan-pam-current.txt
+
clean:
rm -f *~ *.bak
rm -f html/pam*.html
@@ -133,4 +140,6 @@ clean:
rm -f $(TEXTS)
rm -f $(PSFILES) ps/missfont.log
rm -f MODULES-SGML pam.sgml
+ rm -f specs/draft-morgan-pam-current.txt
+ make -C specs/formatter clean