summaryrefslogtreecommitdiff
path: root/doc/adg
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2006-06-28 20:07:11 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2006-06-28 20:07:11 +0000
commit0a4b5f2251382dd87bac17990791e797e82d9748 (patch)
tree3593ed99b4ee302c14dba4f2f6f1f451e0c32394 /doc/adg
parent6c17ca620dc67ef86428ebef2fffa2cff65ca708 (diff)
Relevant BUGIDs:
Purpose of commit: bugfix Commit summary: --------------- Fix make release-docs, remove old directories.
Diffstat (limited to 'doc/adg')
-rw-r--r--doc/adg/Makefile.am26
1 files changed, 22 insertions, 4 deletions
diff --git a/doc/adg/Makefile.am b/doc/adg/Makefile.am
index 6eabeb5a..419a8c6b 100644
--- a/doc/adg/Makefile.am
+++ b/doc/adg/Makefile.am
@@ -6,7 +6,7 @@ CLEANFILES = Linux-PAM_ADG.fo *~
EXTRA_DIST = $(XMLS)
-XMLS = Linux-PAM_ADG.xml $(shell ls pam_*.xml)
+XMLS = Linux-PAM_ADG.xml $(shell ls $(srcdir)/pam_*.xml)
if ENABLE_REGENERATE_MAN
MAINTAINERCLEANFILES = Linux-PAM_ADG.txt Linux-PAM_ADG.pdf html/*.html
@@ -21,7 +21,7 @@ if ENABLE_GENERATE_PDF
--stringparam section.label.includes.component.label 1 \
--stringparam toc.max.depth 3 --xinclude --nonet \
http://docbook.sourceforge.net/release/xsl/current/fo/docbook.xsl $< > Linux-PAM_ADG.fo
- $(FO2PDF) Linux-PAM_ADG.fo $(srcdir)/$@
+ $(FO2PDF) Linux-PAM_ADG.fo $@
else
echo "No fo2pdf processor installed, skip PDF generation"
endif
@@ -32,10 +32,10 @@ Linux-PAM_ADG.txt: $(XMLS)
--stringparam section.autolabel 1 \
--stringparam section.label.includes.component.label 1 \
--stringparam toc.max.depth 3 --xinclude --nonet \
- http://docbook.sourceforge.net/release/xsl/current/html/docbook.xsl $< | $(BROWSER) > $(srcdir)/$@
+ http://docbook.sourceforge.net/release/xsl/current/html/docbook.xsl $< | $(BROWSER) > $@
html/Linux-PAM_ADG.html: $(XMLS)
- @test -d $(srcdir)/html || mkdir -p $(srcdir)/html
+ @test -d html || mkdir -p html
$(XMLLINT) --nonet --xinclude --postvalid --noent --noout $<
$(XSLTPROC) --stringparam base.dir html/ \
--stringparam root.filename Linux-PAM_ADG \
@@ -46,3 +46,21 @@ html/Linux-PAM_ADG.html: $(XMLS)
--stringparam toc.max.depth 3 --xinclude --nonet \
http://docbook.sourceforge.net/release/xsl/current/html/chunk.xsl $<
endif
+
+releasedocs: all
+ test -f html/Linux-PAM_ADG.html && \
+ cp -ap html/Linux-PAM_ADG.html html/adg-*.html \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/html/ || \
+ cp -ap $(srcdir)/html/Linux-PAM_ADG.html \
+ $(srcdir)/html/adg-*.html \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/html/
+ test -f Linux-PAM_ADG.txt && \
+ cp -p Linux-PAM_ADG.txt \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/txt/ || \
+ cp -p $(srcdir)/Linux-PAM_ADG.txt \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/txt/
+ test -f Linux-PAM_ADG.pdf && \
+ cp -p Linux-PAM_ADG.pdf \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/pdf/ || \
+ cp -p $(srcdir)/Linux-PAM_ADG.pdf \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/pdf/