summaryrefslogtreecommitdiff
path: root/doc/man/Makefile.am
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2006-02-12 22:24:34 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2006-02-12 22:24:34 +0000
commitf7827ccfd255e23f285eb8aec7ddf71af94dd6ff (patch)
tree171eea4e7e13be3c8e5d2c4748db91b4244782bf /doc/man/Makefile.am
parent2c388144eb7c68aa31c20c00f6c054c219bf72a2 (diff)
Relevant BUGIDs:
Purpose of commit: cleanup Commit summary: --------------- Merge manual pages and sgml docu as xml, update them. 2006-02-12 Thorsten Kukuk <kukuk@thkukuk.de> * configure.in: Add doc/man/Makefile. * Make.xml.rules: Enable xincludes for manual pages. * doc/Makefile.am (EXRA_DIST): Remove manual pages. (SUBDIR): Add man subdirectory. * doc/man/Makefile.am: New. * doc/man/pam_acct_mgmt.3: New. * doc/man/pam_acct_mgmt.3.xml: New. * doc/man/pam_get_data.3: New. * doc/man/pam_get_data.3.xml: New. * doc/man/pam_set_data.3: New. * doc/man/pam_set_data.3.xml: New. * doc/man/pam.8.xml: New. * doc/man/pam.8: Regenerated from xml file. * doc/man/pam_authenticate.3.xml: New. * doc/man/pam_authenticate.3: Regenerated from xml file. * doc/man/pam_chauthtok.3.xml: New. * doc/man/pam_chauthtok.3: Regenerated from xml file. * doc/man/pam_close_session.3.xml: New. * doc/man/pam_close_session.3: Regenerated from xml file. * doc/man/pam_end.3.xml: New. * doc/man/pam_end.3: Regenerated from xml file. * doc/man/pam_fail_delay.3.xml: New. * doc/man/pam_fail_delay.3: Regenerated from xml file. * doc/man/pam_get_item.3.xml: New. * doc/man/pam_get_item.3: Regenerated from xml file. * doc/man/pam_item_types.inc.xml: New. * doc/man/pam_open_session.3.xml: New. * doc/man/pam_open_session.3: Regenerated from xml file. * doc/man/pam_set_item.3.xml: New. * doc/man/pam_set_item.3: Regenerated from xml file. * doc/man/pam_setcred.3.xml: New. * doc/man/pam_setcred.3: Regenerated from xml file. * doc/man/pam_start.3.xml: New. * doc/man/pam_start.3: Regenerated from xml file. * doc/man/pam_strerror.3.xml: New. * doc/man/pam_strerror.3: Regenerated from xml file. * doc/man/template-man: Removed.
Diffstat (limited to 'doc/man/Makefile.am')
-rw-r--r--doc/man/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/doc/man/Makefile.am b/doc/man/Makefile.am
new file mode 100644
index 00000000..49eefacc
--- /dev/null
+++ b/doc/man/Makefile.am
@@ -0,0 +1,33 @@
+#
+# Copyright (c) 2006 Thorsten Kukuk <kukuk@thkukuk.de>
+#
+
+CLEANFILES = *~
+
+EXTRA_DIST = $(MANS) $(XMLS)
+
+man_MANS = pam.8 pam.conf.5 pam.d.5 \
+ pam_acct_mgmt.3 pam_authenticate.3 \
+ pam_chauthtok.3 pam_close_session.3 \
+ pam_end.3 \
+ pam_fail_delay.3 \
+ pam_get_data.3 pam_get_item.3 \
+ pam_open_session.3 \
+ pam_set_data.3 pam_set_item.3 \
+ pam_setcred.3 pam_start.3 pam_strerror.3
+XMLS = pam.8.xml \
+ pam_acct_mgmt.3.xml pam_authenticate.3.xml \
+ pam_chauthtok.3.xml pam_close_session.3.xml \
+ pam_end.3.xml \
+ pam_fail_delay.3.xml \
+ pam_get_data.3.xml pam_get_item.3.xml \
+ pam_open_session.3.xml \
+ pam_set_data.3.xml pam_set_item.3.xml \
+ pam_setcred.3.xml pam_start.3.xml pam_strerror.3.xml \
+ pam_item_types.inc.xml
+
+if ENABLE_REGENERATE_MAN
+pam_get_item.3: pam_item_types.inc.xml
+pam_set_data.3: pam_item_types.inc.xml
+-include $(top_srcdir)/Make.xml.rules
+endif