summaryrefslogtreecommitdiff
path: root/doc/man/pam_get_item.3
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2006-06-02 15:37:38 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2006-06-02 15:37:38 +0000
commitbad0ed8d159cb77466ed81a624355b1e80ead0dc (patch)
treec1115143eded6faa7e8fe0abc42fc50d4e28fe17 /doc/man/pam_get_item.3
parent29a98911d9cb5e9187c1afe4e161c6861fac4f2b (diff)
Relevant BUGIDs: 1427738
Purpose of commit: new feature/bugfix Commit summary: --------------- 2006-06-02 Thorsten Kukuk <kukuk@thkukuk.de> * doc/man/PAM.8: Regenerate with DocBook XSL Stylesheets v1.70.1. * doc/man/pam.3: Likewise. * doc/man/pam.conf.5: Likewise. * doc/man/pam_acct_mgmt.3: Likewise. * doc/man/pam_authenticate.3: Likewise. * doc/man/pam_chauthtok.3: Likewise. * doc/man/pam_close_session.3: Likewise. * doc/man/pam_conv.3: Likewise. * doc/man/pam_end.3: Likewise. * doc/man/pam_error.3: Likewise. * doc/man/pam_fail_delay.3: Likewise. * doc/man/pam_get_data.3: Likewise. * doc/man/pam_get_item.3: Likewise. * doc/man/pam_get_user.3: Likewise. * doc/man/pam_getenv.3: Likewise. * doc/man/pam_getenvlist.3: Likewise. * doc/man/pam_info.3: Likewise. * doc/man/pam_open_session.3: Likewise. * doc/man/pam_prompt.3: Likewise. * doc/man/pam_putenv.3: Likewise. * doc/man/pam_set_data.3: Likewise. * doc/man/pam_set_item.3: Likewise. * doc/man/pam_setcred.3: Likewise. * doc/man/pam_sm_acct_mgmt.3: Likewise. * doc/man/pam_start.3: Likewise. * doc/man/pam_strerror.3: Likewise. * doc/man/pam_syslog.3: Likewise. * modules/pam_access/access.conf.5: Likewise. * modules/pam_access/pam_access.8: Likewise. * modules/pam_cracklib/pam_cracklib.8: Likewise. * modules/pam_deny/pam_deny.8: Likewise. * modules/pam_echo/pam_echo.8: Likewise. * modules/pam_env/pam_env.8: Likewise. * modules/pam_env/pam_env.conf.5: Likewise. * modules/pam_exec/pam_exec.8: Likewise. * modules/pam_filter/pam_filter.8: Likewise. * modules/pam_ftp/pam_ftp.8: Likewise. * modules/pam_group/group.conf.5: Likewise. * modules/pam_group/pam_group.8: Likewise. * modules/pam_issue/pam_issue.8: Likewise. * modules/pam_lastlog/pam_lastlog.8: Likewise. * modules/pam_mkhomedir/pam_mkhomedir.8: Likewise. * modules/pam_succeed_if/pam_succeed_if.8: Likewise. * modules/pam_umask/pam_umask.8: Likewise. * modules/pam_unix/pam_unix_acct.c (pam_sm_acct_mgmt): Use dngettext if available [#1427738]. * configure.in: Check for dngettext [#1427738]. * po/*.po: Update to dngettext usage. * modules/pam_listfile/Makefile.am: Include Make.xml.rules. * modules/pam_listfile/pam_listfile.8.xml: New. * modules/pam_listfile/pam_listfile.8: New, generated from xml file. * modules/pam_listfile/README.xml: New. * modules/pam_listfile/README: Regenerated from xml file.
Diffstat (limited to 'doc/man/pam_get_item.3')
-rw-r--r--doc/man/pam_get_item.357
1 files changed, 33 insertions, 24 deletions
diff --git a/doc/man/pam_get_item.3 b/doc/man/pam_get_item.3
index 421ef4b5..0c4235a8 100644
--- a/doc/man/pam_get_item.3
+++ b/doc/man/pam_get_item.3
@@ -1,8 +1,11 @@
-.\" ** You probably do not want to edit this file directly **
-.\" It was generated using the DocBook XSL Stylesheets (version 1.69.1).
-.\" Instead of manually editing it, you probably should edit the DocBook XML
-.\" source for it and then use the DocBook XSL Stylesheets to regenerate it.
-.TH "PAM_GET_ITEM" "3" "05/04/2006" "Linux\-PAM Manual" "Linux\-PAM Manual"
+.\" Title: pam_get_item
+.\" Author:
+.\" Generator: DocBook XSL Stylesheets v1.70.1 <http://docbook.sf.net/>
+.\" Date: 06/02/2006
+.\" Manual: Linux\-PAM Manual
+.\" Source: Linux\-PAM Manual
+.\"
+.TH "PAM_GET_ITEM" "3" "06/02/2006" "Linux\-PAM Manual" "Linux\-PAM Manual"
.\" disable hyphenation
.nh
.\" disable justification (adjust text to left margin only)
@@ -10,10 +13,14 @@
.SH "NAME"
pam_get_item \- getting PAM informations
.SH "SYNOPSIS"
-.PP
-\fB#include <security/pam_modules.h>\fR
+.sp
+.ft B
+.nf
+#include <security/pam_modules.h>
+.fi
+.ft
.HP 17
-\fBint\ \fBpam_get_item\fR\fR\fB(\fR\fBconst\ pam_handle_t\ *\fR\fB\fIpamh\fR\fR\fB, \fR\fBint\ \fR\fB\fIitem_type\fR\fR\fB, \fR\fBconst\ void\ **\fR\fB\fIitem\fR\fR\fB);\fR
+.BI "int pam_get_item(const\ pam_handle_t\ *" "pamh" ", int\ " "item_type" ", const\ void\ **" "item" ");"
.SH "DESCRIPTION"
.PP
The
@@ -24,41 +31,42 @@ function allows applications and PAM service modules to access and retrieve PAM
contains a pointer to the value of the corresponding item. Note, this is a pointer to the
\fIactual\fR
data and should
-\fInot\fR
+\fBnot\fR
be
\fIfree()\fR'ed or over\-written! The following values are supported for
\fIitem_type\fR:
-.TP
+.TP 3n
PAM_SERVICE
The service name (which identifies that PAM stack that the PAM functions will use to authenticate the program).
-.TP
+.TP 3n
PAM_USER
The username of the entity under whose identity service will be given. That is, following authentication,
\fIPAM_USER\fR
identifies the local entity that gets to use the service. Note, this value can be mapped from something (eg., "anonymous") to something else (eg. "guest119") by any module in the PAM stack. As such an application should consult the value of
\fIPAM_USER\fR
after each call to a PAM function.
-.TP
+.TP 3n
PAM_USER_PROMPT
The string used when prompting for a user's name. The default value for this string is a localized version of "login: ".
-.TP
+.TP 3n
PAM_TTY
The terminal name: prefixed by
\fI/dev/\fR
if it is a device file; for graphical, X\-based, applications the value for this item should be the
\fI$DISPLAY\fR
variable.
-.TP
+.TP 3n
PAM_RUSER
The requesting user name: local name for a locally requesting user or a remote user name for a remote requesting user.
.sp
Generally an application or module will attempt to supply the value that is most strongly authenticated (a local account before a remote one. The level of trust in this value is embodied in the actual authentication stack associated with the application, so it is ultimately at the discretion of the system administrator.
.sp
+
\fIPAM_RUSER@PAM_RHOST\fR
should always identify the requesting user. In some cases,
\fIPAM_RUSER\fR
may be NULL. In such situations, it is unclear who the requesting entity is.
-.TP
+.TP 3n
PAM_RHOST
The requesting hostname (the hostname of the machine from which the
\fIPAM_RUSER\fR
@@ -67,21 +75,21 @@ entity is requesting service). That is
does identify the requesting user. In some applications,
\fIPAM_RHOST\fR
may be NULL. In such situations, it is unclear where the authentication request is originating from.
-.TP
+.TP 3n
PAM_AUTHTOK
The authentication token (often a password). This token should be ignored by all module functions besides
\fBpam_sm_authenticate\fR(3)
and
\fBpam_sm_chauthtok\fR(3). In the former function it is used to pass the most recent authentication token from one stacked module to another. In the latter function the token is used for another purpose. It contains the currently active authentication token.
-.TP
+.TP 3n
PAM_OLDAUTHTOK
The old authentication token. This token should be ignored by all module functions except
\fBpam_sm_chauthtok\fR(3).
-.TP
+.TP 3n
PAM_CONV
The pam_conv structure. See
\fBpam_conv\fR(3).
-.TP
+.TP 3n
PAM_FAIL_DELAY
A function pointer to redirect centrally managed failure delays. See
\fBpam_fail_delay\fR(3).
@@ -91,26 +99,27 @@ If a service module wishes to obtain the name of the user, it should not use thi
.PP
Only a service module is privileged to read the authentication tokens, PAM_AUTHTOK and PAM_OLDAUTHTOK.
.SH "RETURN VALUES"
-.TP
+.TP 3n
PAM_BAD_ITEM
The application attempted to set an undefined or inaccessible item.
-.TP
+.TP 3n
PAM_BUF_ERR
Memory buffer error.
-.TP
+.TP 3n
PAM_PERM_DENIED
The value of
\fIitem\fR
was NULL.
-.TP
+.TP 3n
PAM_SUCCESS
Data was successful updated.
-.TP
+.TP 3n
PAM_SYSTEM_ERR
The
\fIpam_handle_t\fR
passed as first argument was invalid.
.SH "SEE ALSO"
.PP
+
\fBpam_set_item\fR(3),
\fBpam_strerror\fR(3)