summaryrefslogtreecommitdiff
path: root/doc/mwg/Makefile.am
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2006-06-28 20:07:11 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2006-06-28 20:07:11 +0000
commit0a4b5f2251382dd87bac17990791e797e82d9748 (patch)
tree3593ed99b4ee302c14dba4f2f6f1f451e0c32394 /doc/mwg/Makefile.am
parent6c17ca620dc67ef86428ebef2fffa2cff65ca708 (diff)
Relevant BUGIDs:
Purpose of commit: bugfix Commit summary: --------------- Fix make release-docs, remove old directories.
Diffstat (limited to 'doc/mwg/Makefile.am')
-rw-r--r--doc/mwg/Makefile.am20
1 files changed, 19 insertions, 1 deletions
diff --git a/doc/mwg/Makefile.am b/doc/mwg/Makefile.am
index 249dfbb7..ee650f64 100644
--- a/doc/mwg/Makefile.am
+++ b/doc/mwg/Makefile.am
@@ -6,7 +6,7 @@ CLEANFILES = Linux-PAM_MWG.fo *~
EXTRA_DIST = $(XMLS)
-XMLS = Linux-PAM_MWG.xml $(shell ls pam_*.xml)
+XMLS = Linux-PAM_MWG.xml $(shell ls $(srcdir)/pam_*.xml)
if ENABLE_REGENERATE_MAN
MAINTAINERCLEANFILES = Linux-PAM_MWG.txt Linux-PAM_MWG.pdf html/*.html
@@ -46,3 +46,21 @@ html/Linux-PAM_MWG.html: $(XMLS)
--stringparam toc.max.depth 3 --xinclude --nonet \
http://docbook.sourceforge.net/release/xsl/current/html/chunk.xsl $<
endif
+
+releasedocs: all
+ test -f html/Linux-PAM_MWG.html && \
+ cp -ap html/Linux-PAM_MWG.html html/mwg-*.html \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/html/ || \
+ cp -ap $(srcdir)/html/Linux-PAM_MWG.html \
+ $(srcdir)/html/mwg-*.html \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/html/
+ test -f Linux-PAM_MWG.txt && \
+ cp -p Linux-PAM_MWG.txt \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/txt/ || \
+ cp -p $(srcdir)/Linux-PAM_MWG.txt \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/txt/
+ test -f Linux-PAM_MWG.pdf && \
+ cp -p Linux-PAM_MWG.pdf \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/pdf/ || \
+ cp -p $(srcdir)/Linux-PAM_MWG.pdf \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/pdf/