summaryrefslogtreecommitdiff
path: root/doc/mwg
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2006-09-20 13:46:03 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2006-09-20 13:46:03 +0000
commit8440c76a17e011bef9431c2ac93fc708d7c62e4c (patch)
treee3c4e3455b67e3418e60e9b8d06bd13b82939423 /doc/mwg
parent3cfe9272773f1d6356534b1c30ebaea0a896db93 (diff)
Relevant BUGIDs:
Purpose of commit: new feature/bugfix Commit summary: --------------- 2006-09-20 Thorsten Kukuk <kukuk@thkukuk.de> * doc/adg/Makefile.am: Add manual pages as dependency. * doc/mwg/Makefile.am: Likewise. * doc/sag/Makefile.am: Likewise. * doc/sag/Linux-PAM_SAG.xml: Include pam_unix.xml. * doc/sag/pam_unix.xml: New. * modules/pam_unix/Makefile.am: Generate pam_unix.8 manual page. * modules/pam_unix/README.xml: New. * modules/pam_unix/pam_unix.8.xml: New. * modules/pam_unix/README: Regenerate from XML. * modules/pam_unix/pam_unix.8: Generated from XML.
Diffstat (limited to 'doc/mwg')
-rw-r--r--doc/mwg/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/doc/mwg/Makefile.am b/doc/mwg/Makefile.am
index dbda086f..3d911247 100644
--- a/doc/mwg/Makefile.am
+++ b/doc/mwg/Makefile.am
@@ -7,13 +7,14 @@ CLEANFILES = Linux-PAM_MWG.fo *~
EXTRA_DIST = $(XMLS)
XMLS = Linux-PAM_MWG.xml $(shell ls $(srcdir)/pam_*.xml)
+DEP_XMLS = $(shell ls $(top_srcdir)/doc/man/pam_*.xml)
if ENABLE_REGENERATE_MAN
MAINTAINERCLEANFILES = Linux-PAM_MWG.txt Linux-PAM_MWG.pdf html/*.html
all: Linux-PAM_MWG.txt html/Linux-PAM_MWG.html Linux-PAM_MWG.pdf
-Linux-PAM_MWG.pdf: $(XMLS)
+Linux-PAM_MWG.pdf: $(XMLS) $(DEP_XMLS)
if ENABLE_GENERATE_PDF
$(XMLLINT) --nonet --xinclude --postvalid --noent --noout $<
$(XSLTPROC) --stringparam generate.toc "book toc" \
@@ -26,7 +27,7 @@ else
echo "No fo2pdf processor installed, skip PDF generation"
endif
-Linux-PAM_MWG.txt: $(XMLS)
+Linux-PAM_MWG.txt: $(XMLS) $(DEP_XMLS)
$(XMLLINT) --nonet --xinclude --postvalid --noent --noout $<
$(XSLTPROC) --stringparam generate.toc "book toc" \
--stringparam section.autolabel 1 \
@@ -34,7 +35,7 @@ Linux-PAM_MWG.txt: $(XMLS)
--stringparam toc.max.depth 3 --xinclude --nonet \
http://docbook.sourceforge.net/release/xsl/current/html/docbook.xsl $< | $(BROWSER) > $@
-html/Linux-PAM_MWG.html: $(XMLS)
+html/Linux-PAM_MWG.html: $(XMLS) $(DEP_XMLS)
@test -d html || mkdir -p html
$(XMLLINT) --nonet --xinclude --postvalid --noent --noout $<
$(XSLTPROC) --stringparam base.dir html/ \