summaryrefslogtreecommitdiff
path: root/doc/specs/Makefile.am
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2005-09-26 12:49:52 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2005-09-26 12:49:52 +0000
commit96eb2dc401f785e2b35a2089dda24416ff9bb305 (patch)
treef8bc936e8000c35bbccc3234535e513b48d20db4 /doc/specs/Makefile.am
parenta3741192151aaf4b4d26f97fe470c9e7ea34703e (diff)
Relevant BUGIDs: none
Purpose of commit: bugfix Commit summary: --------------- Fix spec generation and creating tar archive with automake: * configure.in: Add doc/specs/Makefile. * Makefile.am: Add releasedocs rule. * doc/Makefile.am: Add specs subdir, remove files from specs directory, add rfc86.0.txt to releasedocs. * doc/specs/Makefile.am: New file. * doc/specs/formatter/parse.y: move from here ... * doc/specs/parse.y: ... here. * doc/specs/formatter/parse.lex: move from here ... * doc/specs/parse.lex: ... here.
Diffstat (limited to 'doc/specs/Makefile.am')
-rw-r--r--doc/specs/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/doc/specs/Makefile.am b/doc/specs/Makefile.am
new file mode 100644
index 00000000..749f0ba7
--- /dev/null
+++ b/doc/specs/Makefile.am
@@ -0,0 +1,23 @@
+#
+# Copyright (c) 2005 Thorsten Kukuk <kukuk@suse.de>
+#
+
+CLEANFILES = draft-morgan-pam-current.txt *~
+
+EXTRA_DIST = draft-morgan-pam.raw std-agent-id.raw rfc86.0.txt lex.yy.c
+
+all: padout spec
+
+spec: draft-morgan-pam.raw
+ ./padout < draft-morgan-pam.raw > draft-morgan-pam-current.txt
+
+noinst_PROGRAMS = padout
+
+padout_SOURCES = parse.y parse.lex
+
+padout_LDADD = @LEXLIB@
+
+parse.c: lex.yy.c
+
+lex.yy.c: parse.lex
+ $(LEX) parse.lex