summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorDmitry V. Levin <ldv@altlinux.org>2014-12-09 01:21:48 +0000
committerDmitry V. Levin <ldv@altlinux.org>2014-12-09 10:12:21 +0000
commit8da3f3c38e075498a24fb9db80ae9862bda7154d (patch)
tree5bc7d58a9951a7e50925c7d5cd9a5b035c8df997 /doc
parent4a4dd12c9ba83343374c9e1184c94426c9803527 (diff)
Do not use yywrap (ticket #42)
Our scanners do not really use yywrap. Explicitly disable yywrap so that no references to yywrap will be generated and no LEXLIB would be needed. * conf/pam_conv1/Makefile.am (pam_conv1_LDADD): Remove. * conf/pam_conv1/pam_conv_l.l: Enable noyywrap option. * doc/specs/Makefile.am (padout_LDADD): Remove. * doc/specs/parse_l.l: Enable noyywrap option.
Diffstat (limited to 'doc')
-rw-r--r--doc/specs/Makefile.am2
-rw-r--r--doc/specs/parse_l.l1
2 files changed, 1 insertions, 2 deletions
diff --git a/doc/specs/Makefile.am b/doc/specs/Makefile.am
index 26882207..36d53baf 100644
--- a/doc/specs/Makefile.am
+++ b/doc/specs/Makefile.am
@@ -21,6 +21,4 @@ noinst_PROGRAMS = padout
padout_SOURCES = parse_l.l parse_y.y
-padout_LDADD = @LEXLIB@
-
doc_DATA = draft-morgan-pam-current.txt rfc86.0.txt
diff --git a/doc/specs/parse_l.l b/doc/specs/parse_l.l
index 7cab424c..d8400a07 100644
--- a/doc/specs/parse_l.l
+++ b/doc/specs/parse_l.l
@@ -8,6 +8,7 @@
#include "parse_y.h"
%}
+%option noyywrap
%%
\#[\$]+[a-zA-Z]*(\=[0-9]+)? return NEW_COUNTER;