summaryrefslogtreecommitdiff
path: root/examples/Makefile
diff options
context:
space:
mode:
authorAndrew G. Morgan <morgan@kernel.org>2001-10-11 04:14:30 +0000
committerAndrew G. Morgan <morgan@kernel.org>2001-10-11 04:14:30 +0000
commit345044121bc4e8977a22d6235d31df4b2114a240 (patch)
tree9b76c2ed9812a14a9f212db8e46ab86ad39ce7b2 /examples/Makefile
parent6180f388df5004d5435cd6912445130cf260f94e (diff)
Relevant BUGIDs: 463984
Purpose of commit: bugfix Commit summary: --------------- The last fix to the conversation function was less than marginal: it didn't actually work! This second commit adds the all important 'return the user's input' bit! Also added some more D() stuff to pam_misc to help locate the problem and finally cleaned up the Makefile in the examples/ directory. I used xsh to do the testing.
Diffstat (limited to 'examples/Makefile')
-rw-r--r--examples/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/examples/Makefile b/examples/Makefile
index e9432ba7..58600f49 100644
--- a/examples/Makefile
+++ b/examples/Makefile
@@ -16,8 +16,7 @@ endif
CFLAGS += -I../libpam_misc/include -I../libpamc/include
-LOADLIBES = -L../libpam -L../libpamc -L../libpam_misc \
- -lpam$(LIBSUFFIX) -lpam_misc$(LIBSUFFIX)
+LOADLIBES = -L../libpam -L../libpamc -L../libpam_misc -lpam -lpam_misc
ifeq ($(STATIC_LIBPAM),yes)
ifneq ($(DYNAMIC),)