summaryrefslogtreecommitdiff
path: root/examples/Makefile
diff options
context:
space:
mode:
authorAndrew G. Morgan <morgan@kernel.org>2002-06-27 04:04:54 +0000
committerAndrew G. Morgan <morgan@kernel.org>2002-06-27 04:04:54 +0000
commit09d18a79f0e11ad5dd90e3007f7ae688bc50693c (patch)
treeee50cca9c611775ad78ab619ace5dd6d5b1eb1ac /examples/Makefile
parente509c5af6f70eb3cfd846004b82caaca24fd4a3b (diff)
Relevant BUGIDs: 565470
Purpose of commit: bugfix Commit summary: --------------- It seems that configure was barfing on some packages because libpam_misc could not compile without also being linked to libpam.
Diffstat (limited to 'examples/Makefile')
-rw-r--r--examples/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/examples/Makefile b/examples/Makefile
index 58600f49..7cabccaa 100644
--- a/examples/Makefile
+++ b/examples/Makefile
@@ -14,9 +14,10 @@ else
LIBSUFFIX=
endif
-CFLAGS += -I../libpam_misc/include -I../libpamc/include
+CFLAGS += -I$(absolute_srcdir)/libpam_misc/include
-LOADLIBES = -L../libpam -L../libpamc -L../libpam_misc -lpam -lpam_misc
+LOADLIBES = -L$(absolute_objdir)/libpam -L$(absolute_objdir)/libpamc \
+ -L$(absolute_objdir)/libpam_misc -lpam -lpam_misc
ifeq ($(STATIC_LIBPAM),yes)
ifneq ($(DYNAMIC),)