summaryrefslogtreecommitdiff
path: root/examples/Makefile
diff options
context:
space:
mode:
authorAndrew G. Morgan <morgan@kernel.org>2001-02-10 07:17:52 +0000
committerAndrew G. Morgan <morgan@kernel.org>2001-02-10 07:17:52 +0000
commitd66ecd8caf597bcc794f9b9b1716a4f4ab4cfed2 (patch)
tree6e4ba1066ad59fbc3e4ae1ef099e74e65de00b8e /examples/Makefile
parent63b197ed633d413f976c644b2693ed084bcfee6e (diff)
Relevant BUGIDs: 131783
Purpose of commit: bugfix Commit summary: --------------- static library and debugging library support fixed - post autoconf stuff.
Diffstat (limited to 'examples/Makefile')
-rw-r--r--examples/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/examples/Makefile b/examples/Makefile
index 0e985c59..e9432ba7 100644
--- a/examples/Makefile
+++ b/examples/Makefile
@@ -8,9 +8,23 @@ PROGS = blank xsh check_user
SRCS = blank.c xsh.c check_user.c
PROGSUID =
+ifeq ($(WITH_LIBDEBUG),yes)
+ LIBSUFFIX=d
+else
+ LIBSUFFIX=
+endif
+
CFLAGS += -I../libpam_misc/include -I../libpamc/include
-LOADLIBES = -L../libpam -L../libpamc -L../libpam_misc -lpam -lpam_misc
+LOADLIBES = -L../libpam -L../libpamc -L../libpam_misc \
+ -lpam$(LIBSUFFIX) -lpam_misc$(LIBSUFFIX)
+
+ifeq ($(STATIC_LIBPAM),yes)
+ ifneq ($(DYNAMIC),)
+ CFLAGS += $(CC_STATIC)
+ LOADLIBES += $(LIBDL)
+ endif
+endif
all: $(PROGS)