summaryrefslogtreecommitdiff
path: root/examples/xsh.c
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2006-08-31 11:06:15 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2006-08-31 11:06:15 +0000
commit89c393b73d9e4c7fa1adaea4ed17047215bdb942 (patch)
tree6083daacc5427db0094f5d787fb906926dccd03b /examples/xsh.c
parent160a0b2ce1d8c5fb9acf3faa506094df285996f3 (diff)
Relevant BUGIDs:
Purpose of commit: bugfix Commit summary: --------------- Fix some bugs on older distributions 2006-08-31 Thorsten Kukuk <kukuk@thkukuk.de> * modules/pam_namespace/Makefile.am: Don't install manual page if we don't build module. * m4/ld-as-needed.m4: Don't set LDFLAGS if check failed. * m4/ld-O1: Likewise.
Diffstat (limited to 'examples/xsh.c')
-rw-r--r--examples/xsh.c6
1 files changed, 1 insertions, 5 deletions
diff --git a/examples/xsh.c b/examples/xsh.c
index 08b4af11..ef4dca0c 100644
--- a/examples/xsh.c
+++ b/examples/xsh.c
@@ -1,7 +1,3 @@
-/*
- * $Id$
- */
-
/* Andrew Morgan (morgan@kernel.org) -- an example application
* that invokes a shell, based on blank.c */
@@ -143,7 +139,7 @@ int main(int argc, char **argv)
(const char *)username);
/* this is always a really bad thing for security! */
- system("/bin/sh");
+ retcode = system("/bin/sh");
/* close a session for the user --- `0' could be PAM_SILENT
* it is possible that this pam_close_call is in another program..