summaryrefslogtreecommitdiff
path: root/libpam/include/security/_pam_types.h
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2006-01-05 13:00:28 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2006-01-05 13:00:28 +0000
commit7308b7954b02c4fd7e34c7b01a1099ec59751b9a (patch)
tree74df321db215613ce03137129fe4661bd42634dc /libpam/include/security/_pam_types.h
parente4cbefcdd253ae67503268014ef39e849cb31b7b (diff)
Relevant BUGIDs: none
Purpose of commit: bugfix Commit summary: --------------- item of pam_get_item() is allowed to be NULL and the behavior is documented, so we have to allow it. 2006-01-05 Thorsten Kukuk <kukuk@thkukuk.de> * libpam/include/security/_pam_types.h: Remove nonnull attribute from third paramter (item) of pam_get_item. * libpam/Makefile.am: Bump version number of shared library.
Diffstat (limited to 'libpam/include/security/_pam_types.h')
-rw-r--r--libpam/include/security/_pam_types.h7
1 files changed, 3 insertions, 4 deletions
diff --git a/libpam/include/security/_pam_types.h b/libpam/include/security/_pam_types.h
index 6815b459..a55dba9c 100644
--- a/libpam/include/security/_pam_types.h
+++ b/libpam/include/security/_pam_types.h
@@ -171,7 +171,7 @@ typedef struct pam_handle pam_handle_t;
extern int PAM_NONNULL((1))
pam_set_item(pam_handle_t *pamh, int item_type, const void *item);
-extern int PAM_NONNULL((1,3))
+extern int PAM_NONNULL((1))
pam_get_item(const pam_handle_t *pamh, int item_type, const void **item);
extern const char *
@@ -309,13 +309,13 @@ struct pam_conv {
* 3. The name of the author may not be used to endorse or promote
* products derived from this software without specific prior
* written permission.
- *
+ *
* ALTERNATIVELY, this product may be distributed under the terms of
* the GNU Public License, in which case the provisions of the GPL are
* required INSTEAD OF the above restrictions. (This clause is
* necessary due to a potential bad interaction between the GPL and
* the restrictions contained in a BSD-style copyright.)
- *
+ *
* THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESS OR IMPLIED
* WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
* OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
@@ -329,4 +329,3 @@ struct pam_conv {
* OF THE POSSIBILITY OF SUCH DAMAGE. */
#endif /* _SECURITY__PAM_TYPES_H */
-