summaryrefslogtreecommitdiff
path: root/libpam/include/security/pam_ext.h
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2008-12-03 14:16:33 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2008-12-03 14:16:33 +0000
commitf326d04ccd16631d57134487e56bb73074f0dd0e (patch)
treebe55fce45e805e98057c1920a5f0ebaffa2b6650 /libpam/include/security/pam_ext.h
parentde63f0160c57494553e400aca215ffe316e946b7 (diff)
Relevant BUGIDs:
Purpose of commit: new feature Commit summary: --------------- 2008-12-03 Thorsten Kukuk <kukuk@suse.de> * doc/man/Makefile.am: Add pam_get_authtok.3.xml. * doc/man/pam_get_authtok.3.xml: New. * libpam/Makefile.am: Add pam_get_authtok.c. * libpam/libpam.map: Export pam_get_authtok. * libpam/pam_get_authtok.c: New. * libpam/pam_private.h: Add mod_argc and mod_argv to pam_handle. * libpam_include/security/pam_ext.h: Add pam_get_authtok prototype. * modules/pam_cracklib/pam_cracklib.c: Use pam_get_authtok. * modules/pam_pwhistory/pam_pwhistory.c: Likewise. * po/POTFILES.in: Add libpam/pam_get_authtok.c. * xtests/tst-pam_cracklib1.c: Adjust error codes. * modules/pam_timestamp/Makefile.am: Remove hmactest.c from EXTRA_DIST. * po/*.po: Regenerated.
Diffstat (limited to 'libpam/include/security/pam_ext.h')
-rw-r--r--libpam/include/security/pam_ext.h5
1 files changed, 4 insertions, 1 deletions
diff --git a/libpam/include/security/pam_ext.h b/libpam/include/security/pam_ext.h
index 111dd633..26f7156c 100644
--- a/libpam/include/security/pam_ext.h
+++ b/libpam/include/security/pam_ext.h
@@ -1,5 +1,5 @@
/*
- * Copyright (C) 2005, 2006 Thorsten Kukuk.
+ * Copyright (C) 2005, 2006, 2008 Thorsten Kukuk.
*
* <security/pam_ext.h>
*
@@ -74,6 +74,9 @@ pam_prompt (pam_handle_t *pamh, int style, char **response,
#define pam_info(pamh, fmt...) pam_prompt(pamh, PAM_TEXT_INFO, NULL, fmt)
#define pam_vinfo(pamh, fmt, args) pam_vprompt(pamh, PAM_TEXT_INFO, NULL, fmt, args)
+extern int PAM_NONNULL((1,3))
+pam_get_authtok (pam_handle_t *pamh, int item, const char **authtok,
+ const char *prompt);
#ifdef __cplusplus
}
#endif