summaryrefslogtreecommitdiff
path: root/libpam/include/security
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2009-11-10 15:52:20 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2009-11-10 15:52:20 +0000
commit0674700d17431655b4be03de6119ada78164266b (patch)
tree6ea8c9d3346ff231f375f484fef29e521f50a424 /libpam/include/security
parentcf360646cafc2f84d7a601d9681555c4d43e713b (diff)
Relevant BUGIDs:
Purpose of commit: regression fix Commit summary: --------------- 2009-11-10 Thorsten Kukuk <kukuk@suse.de> * doc/man/pam_get_authtok.3.xml: Document pam_get_authtok_noverify and pam_get_authtok_verify. * libpam/Makefile.am (libpam_la_LDFLAGS): Bump revesion of libpam. * libpam/pam_get_authtok.c (pam_get_authtok_internal): Renamed from pam_get_authtok, add flags argument, always check return values. * modules/pam_cracklib/pam_cracklib.c (pam_sm_chauthtok): Use pam_get_authtok_noverify and pam_get_authtok_verify. * libpam/include/security/pam_ext.h: Add prototypes for pam_get_authtok_noverify and pam_get_authtok_verify. * libpam/libpam.map: Add new pam_get_authtok_* functions.
Diffstat (limited to 'libpam/include/security')
-rw-r--r--libpam/include/security/pam_ext.h9
1 files changed, 8 insertions, 1 deletions
diff --git a/libpam/include/security/pam_ext.h b/libpam/include/security/pam_ext.h
index 26f7156c..7542861a 100644
--- a/libpam/include/security/pam_ext.h
+++ b/libpam/include/security/pam_ext.h
@@ -1,5 +1,5 @@
/*
- * Copyright (C) 2005, 2006, 2008 Thorsten Kukuk.
+ * Copyright (C) 2005, 2006, 2008, 2009 Thorsten Kukuk.
*
* <security/pam_ext.h>
*
@@ -77,6 +77,13 @@ pam_prompt (pam_handle_t *pamh, int style, char **response,
extern int PAM_NONNULL((1,3))
pam_get_authtok (pam_handle_t *pamh, int item, const char **authtok,
const char *prompt);
+extern int PAM_NONNULL((1,2))
+pam_get_authtok_noverify (pam_handle_t *pamh, const char **authtok,
+ const char *prompt);
+extern int PAM_NONNULL((1,2))
+pam_get_authtok_verify (pam_handle_t *pamh, const char **authtok,
+ const char *prompt);
+
#ifdef __cplusplus
}
#endif