summaryrefslogtreecommitdiff
path: root/libpam/pam_private.h
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2008-12-03 14:16:33 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2008-12-03 14:16:33 +0000
commitf326d04ccd16631d57134487e56bb73074f0dd0e (patch)
treebe55fce45e805e98057c1920a5f0ebaffa2b6650 /libpam/pam_private.h
parentde63f0160c57494553e400aca215ffe316e946b7 (diff)
Relevant BUGIDs:
Purpose of commit: new feature Commit summary: --------------- 2008-12-03 Thorsten Kukuk <kukuk@suse.de> * doc/man/Makefile.am: Add pam_get_authtok.3.xml. * doc/man/pam_get_authtok.3.xml: New. * libpam/Makefile.am: Add pam_get_authtok.c. * libpam/libpam.map: Export pam_get_authtok. * libpam/pam_get_authtok.c: New. * libpam/pam_private.h: Add mod_argc and mod_argv to pam_handle. * libpam_include/security/pam_ext.h: Add pam_get_authtok prototype. * modules/pam_cracklib/pam_cracklib.c: Use pam_get_authtok. * modules/pam_pwhistory/pam_pwhistory.c: Likewise. * po/POTFILES.in: Add libpam/pam_get_authtok.c. * xtests/tst-pam_cracklib1.c: Adjust error codes. * modules/pam_timestamp/Makefile.am: Remove hmactest.c from EXTRA_DIST. * po/*.po: Regenerated.
Diffstat (limited to 'libpam/pam_private.h')
-rw-r--r--libpam/pam_private.h2
1 files changed, 2 insertions, 0 deletions
diff --git a/libpam/pam_private.h b/libpam/pam_private.h
index 62756ad4..777fd2d7 100644
--- a/libpam/pam_private.h
+++ b/libpam/pam_private.h
@@ -162,6 +162,8 @@ struct pam_handle {
struct _pam_former_state former; /* library state - support for
event driven applications */
const char *mod_name; /* Name of the module currently executed */
+ int mod_argc; /* Number of module arguments */
+ char **mod_argv; /* module arguments */
int choice; /* Which function we call from the module */
#ifdef HAVE_LIBAUDIT