summaryrefslogtreecommitdiff
path: root/libpam/pam_tokens.h
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2006-01-24 23:28:31 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2006-01-24 23:28:31 +0000
commit8d5b793b25a66e6657f5fdbeab96e1feac0d56af (patch)
treebbf4487e537da00949fb92a413137425e80c6187 /libpam/pam_tokens.h
parentc14d282c2a5fefbf7060d05b9d1910b359a1566f (diff)
Relevant BUGIDs:
Purpose of commit: new feature Commit summary: --------------- Add framework for manpages in xml source Fix --enable-static-modules 2006-01-24 Thorsten Kukuk <kukuk@thkukuk.de> * libpam/pam_static_modules.h: New. * Makefile.am: Reorder subdirectories for static modules. * configure.in: Add --enable-static-modules option. * libpam/Makefile.am: Define WITH_SELINUX and WITH_PWDB if necessary, add pam_static_modules.h, link against all PAM module object files if STATIC_MODULES is defined. * libpam/pam_static.c: Remove old _static_module* includes, include pam_static_modules.h. * configure.in: Add checks for xsltproc, xmllint and docbook xsl stylesheet. * m4/jh_path_xml_catalog.m4: New.
Diffstat (limited to 'libpam/pam_tokens.h')
-rw-r--r--libpam/pam_tokens.h8
1 files changed, 7 insertions, 1 deletions
diff --git a/libpam/pam_tokens.h b/libpam/pam_tokens.h
index fad30759..fcda7ec2 100644
--- a/libpam/pam_tokens.h
+++ b/libpam/pam_tokens.h
@@ -17,6 +17,9 @@
/* an array of actions */
+#ifndef LIBPAM_COMPILE
+static
+#endif
const char * const _pam_token_actions[-_PAM_ACTION_UNDEF] = {
"ignore", /* 0 */
"ok", /* -1 */
@@ -28,6 +31,9 @@ const char * const _pam_token_actions[-_PAM_ACTION_UNDEF] = {
/* an array of possible return values */
+#ifndef LIBPAM_COMPILE
+static
+#endif
const char * const _pam_token_returns[_PAM_RETURN_VALUES+1] = {
"success", /* 0 */
"open_err", /* 1 */
@@ -41,7 +47,7 @@ const char * const _pam_token_returns[_PAM_RETURN_VALUES+1] = {
"authinfo_unavail", /* 9 */
"user_unknown", /* 10 */
"maxtries", /* 11 */
- "new_authtok_reqd", /* 12 */
+ "new_authtok_reqd", /* 12 */
"acct_expired", /* 13 */
"session_err", /* 14 */
"cred_unavail", /* 15 */