summaryrefslogtreecommitdiff
path: root/libpam
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2006-06-28 07:22:40 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2006-06-28 07:22:40 +0000
commit62101bd49ce2f8b797d361c87762853c56d2481a (patch)
tree2a615da258847840fda55fb761714db4fd5ba83f /libpam
parent421783d65ea2b7d80923378b8ef3c566ca63583c (diff)
Relevant BUGIDs:
Purpose of commit: new feature/big release cleanup Commit summary: --------------- Big cleanup to get 0.99.5.0 release done: 2006-06-28 Thorsten Kukuk <kukuk@thkukuk.de> * bump version number to 0.99.5.0 * modules/pam_rhosts/pam_rhosts.c: New module, replaces pam_rhosts_auth.so. * modules/pam_rhosts/pam_rhosts.8.xml: New. * modules/pam_rhosts/pam_rhosts.8: New, generated from XML source. * modules/pam_rhosts/tst-pam_rhosts: New. * modules/pam_rhosts/Makefile.am: Add pam_rhosts, generate manual page and README. * modules/pam_rhosts/README.xml: New. * modules/pam_rhosts/reADME: Regenerated from XML source. * doc/man/pam_sm_acct_mgmt.3.xml: Adjust syntax for module writers guide. * doc/man/pam_sm_authenticate.3.xml: Likewise. * doc/man/pam_sm_chauthtok.3.xml: Likewise. * doc/man/pam_sm_close_session.3.xml: Likewise. * doc/man/pam_sm_open_session.3.xml: Likewise. * doc/man/pam_sm_setcred.3.xml: Likewise. * po/POTFILES.in: Add new source files. * libpam/pam_static_modules.h: Add new modules. * modules/pam_keyinit.c: Add _pam_keyinit_modstruct.
Diffstat (limited to 'libpam')
-rw-r--r--libpam/pam_static_modules.h10
1 files changed, 10 insertions, 0 deletions
diff --git a/libpam/pam_static_modules.h b/libpam/pam_static_modules.h
index 00e2a9b5..92a367ac 100644
--- a/libpam/pam_static_modules.h
+++ b/libpam/pam_static_modules.h
@@ -44,6 +44,7 @@ extern struct pam_module _pam_filter_modstruct;
extern struct pam_module _pam_ftp_modstruct;
extern struct pam_module _pam_group_modstruct;
extern struct pam_module _pam_issue_modstruct;
+extern struct pam_module _pam_keyinit_modstruct;
extern struct pam_module _pam_lastlog_modstruct;
extern struct pam_module _pam_limits_modstruct;
extern struct pam_module _pam_listfile_modstruct;
@@ -51,8 +52,12 @@ extern struct pam_module _pam_localuser_modstruct;
extern struct pam_module _pam_mail_modstruct;
extern struct pam_module _pam_mkhomedir_modstruct;
extern struct pam_module _pam_motd_modstruct;
+#ifdef HAVE_UNSHARE
+extern struct pam_module _pam_namespace;
+#endif
extern struct pam_module _pam_nologin_modstruct;
extern struct pam_module _pam_permit_modstruct;
+extern struct pam_module _pam_rhosts_modstruct;
extern struct pam_module _pam_rhosts_auth_modstruct;
extern struct pam_module _pam_rootok_modstruct;
extern struct pam_module _pam_securetty_modstruct;
@@ -89,6 +94,7 @@ static struct pam_module *static_modules[] = {
&_pam_ftp_modstruct,
&_pam_group_modstruct,
&_pam_issue_modstruct,
+ &_pam_keyinit_modstruct,
&_pam_lastlog_modstruct,
&_pam_limits_modstruct,
&_pam_listfile_modstruct,
@@ -96,8 +102,12 @@ static struct pam_module *static_modules[] = {
&_pam_mail_modstruct,
&_pam_mkhomedir_modstruct,
&_pam_motd_modstruct,
+#ifdef HAVE_UNSHARE
+ &_pam_namespace,
+#endif
&_pam_nologin_modstruct,
&_pam_permit_modstruct,
+ &_pam_rhosts_modstruct,
&_pam_rhosts_auth_modstruct,
&_pam_rootok_modstruct,
&_pam_securetty_modstruct,