summaryrefslogtreecommitdiff
path: root/libpam
diff options
context:
space:
mode:
authorAndrew G. Morgan <morgan@kernel.org>2001-02-10 07:17:52 +0000
committerAndrew G. Morgan <morgan@kernel.org>2001-02-10 07:17:52 +0000
commitd66ecd8caf597bcc794f9b9b1716a4f4ab4cfed2 (patch)
tree6e4ba1066ad59fbc3e4ae1ef099e74e65de00b8e /libpam
parent63b197ed633d413f976c644b2693ed084bcfee6e (diff)
Relevant BUGIDs: 131783
Purpose of commit: bugfix Commit summary: --------------- static library and debugging library support fixed - post autoconf stuff.
Diffstat (limited to 'libpam')
-rw-r--r--libpam/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/libpam/Makefile b/libpam/Makefile
index 64fe13a4..80fbf957 100644
--- a/libpam/Makefile
+++ b/libpam/Makefile
@@ -40,6 +40,8 @@ ifdef STATIC
@echo Did you mean to set STATIC\?
MODULES = $(shell cat ../modules/_static_module_objects)
STATICOBJ = pam_static.o
+else
+MODULES =
endif
ifdef MEMORY_DEBUG
@@ -105,7 +107,7 @@ endif
$(LIBPAMSTATIC): $(SLIBOBJECTS)
ifeq ($(STATIC_LIBPAM),yes)
- $(AR) $@ $(SLIBOBJECTS) $(MODULES)
+ ar cr $@ $(SLIBOBJECTS) $(MODULES)
$(RANLIB) $@
endif