summaryrefslogtreecommitdiff
path: root/libpam_misc
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2003-11-27 07:54:20 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2003-11-27 07:54:20 +0000
commitad89e8953313866982bfd5bc69eab42a2b2b666d (patch)
tree2bab066758ab6ba19bb52075b0e7bebf107ae098 /libpam_misc
parent6216e61ca2ed39128a9d29ec2d7e389addb4812e (diff)
Relevant BUGIDs: 850092
Purpose of commit: bugfix Commit summary: --------------- Using the fakeroot option as normal user does not work, since we call ldconfig, which aborts with an error message if not called as root due missing permissions. Fixed by calling ldconfig with -n library path option if FAKEROOT is set.
Diffstat (limited to 'libpam_misc')
-rw-r--r--libpam_misc/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/libpam_misc/Makefile b/libpam_misc/Makefile
index e9b1a6c1..16ba07e6 100644
--- a/libpam_misc/Makefile
+++ b/libpam_misc/Makefile
@@ -84,7 +84,11 @@ install: all
ifeq ($(DYNAMIC_LIBPAM),yes)
$(MKDIR) $(FAKEROOT)$(libdir)
$(INSTALL) -m $(SHLIBMODE) $(LIBNAMED) $(FAKEROOT)$(libdir)/$(LIBNAMEDFULL)
+ifndef FAKEROOT
$(LDCONFIG)
+else
+ $(LDCONFIG) -n $(FAKEROOT)$(libdir)
+endif
ifneq ($(DYNTYPE),"sl")
( cd $(FAKEROOT)$(libdir) ; rm -f $(LIBNAMED) ; ln -s $(LIBNAMEDNAME) $(LIBNAMED) )
endif