summaryrefslogtreecommitdiff
path: root/m4/japhar_grep_cflags.m4
diff options
context:
space:
mode:
authorDmitry V. Levin <ldv@altlinux.org>2020-08-06 18:00:00 +0000
committerDmitry V. Levin <ldv@altlinux.org>2020-08-07 08:00:00 +0000
commit84726f58785a22847cb67c2e009b5be0e207a256 (patch)
tree4d2b87abc2c127f6fe01d75a1074c01df5c8fbe8 /m4/japhar_grep_cflags.m4
parent650273e77b643f14d937f26f8b628481a4b4b56a (diff)
m4: rewrite __attribute__((unused)) check
Rewrite using AC_CACHE_CHECK to create a more readable autoconf macro. * m4/attribute.m4: New file. * m4/japhar_grep_cflags.m4: Remove. * m4/.gitignore: Replace japhar_grep_cflags.m4 with attribute.m4. * configure.ac: Replace AC_C___ATTRIBUTE__ with PAM_ATTRIBUTE_UNUSED.
Diffstat (limited to 'm4/japhar_grep_cflags.m4')
-rw-r--r--m4/japhar_grep_cflags.m432
1 files changed, 0 insertions, 32 deletions
diff --git a/m4/japhar_grep_cflags.m4 b/m4/japhar_grep_cflags.m4
deleted file mode 100644
index 4e8c4598..00000000
--- a/m4/japhar_grep_cflags.m4
+++ /dev/null
@@ -1,32 +0,0 @@
-dnl
-dnl Test for __attribute__ ((unused))
-dnl Based on code from the tcpdump version 3.7.2 source.
-dnl
-
-AC_DEFUN([AC_C___ATTRIBUTE__], [
-AC_MSG_CHECKING(for __attribute__)
-AC_CACHE_VAL(ac_cv___attribute__, [
-AC_COMPILE_IFELSE([
-AC_LANG_PROGRAM([[
-#include <stdlib.h>
-static void foo (void) __attribute__ ((unused));
-
-static void
-foo (void)
-{
- exit(1);
-}
-]],
-[[
- exit (0);
-]])],
-[ac_cv___attribute__=yes],
-[ac_cv___attribute__=no])])
-if test "$ac_cv___attribute__" = "yes"; then
- AC_DEFINE(UNUSED, __attribute__ ((unused)), [define if your compiler has __att
-ribute__ ((unused))])
-else
- AC_DEFINE(UNUSED,,)
-fi
-AC_MSG_RESULT($ac_cv___attribute__)
-])