summaryrefslogtreecommitdiff
path: root/modules/Makefile.am
diff options
context:
space:
mode:
authorPavel Březina <pbrezina@redhat.com>2020-01-10 15:53:35 +0100
committerTomáš Mráz <t8m@users.noreply.github.com>2020-01-28 12:24:13 +0100
commit926d7935edf35385e6c28bb97666aee443b71e46 (patch)
treeeaf1b725e24359dbd4e7a1f73450a8b20cd05f77 /modules/Makefile.am
parent4dd9b97b762cc73816cb867d49c9d0d0b91d642c (diff)
pam_usertype: new module to tell if uid is in login.defs ranges
This module will check if the user account type is system or regular based on its uid. To evaluate the condition it will use 0-99 reserved range together with `SYS_UID_MIN` and `SYS_UID_MAX` values from `/etc/login.defs`. If these values are not set, it uses configure-time defaults `--with-sys-uid-min` and `--with-uid-min` (according to `login.defs` man page `SYS_UID_MAX` defaults to `UID_MIN - 1`. This information can be used to skip specific module in pam stack based on the account type. `pam_succeed_if uid < 1000` is used at the moment however it does not reflect changes to `login.defs`.
Diffstat (limited to 'modules/Makefile.am')
-rw-r--r--modules/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/modules/Makefile.am b/modules/Makefile.am
index 612fc740..d9659cb7 100644
--- a/modules/Makefile.am
+++ b/modules/Makefile.am
@@ -19,7 +19,7 @@ SUBDIRS := pam_access pam_cracklib pam_debug pam_deny pam_echo \
pam_selinux pam_sepermit pam_shells pam_stress \
pam_succeed_if pam_tally pam_tally2 pam_time pam_timestamp \
pam_tty_audit pam_umask \
- pam_unix pam_userdb pam_warn pam_wheel pam_xauth \
+ pam_unix pam_userdb pam_usertype pam_warn pam_wheel pam_xauth \
$(MAYBE_PAM_RHOSTS) $(MAYBE_PAM_LASTLOG)
CLEANFILES = *~