summaryrefslogtreecommitdiff
path: root/modules/Makefile
diff options
context:
space:
mode:
authorAndrew G. Morgan <morgan@kernel.org>2001-12-09 22:15:11 +0000
committerAndrew G. Morgan <morgan@kernel.org>2001-12-09 22:15:11 +0000
commitda67a7d6126846939fd43b1ddb5aa8c06ee09301 (patch)
treee9df9e69023b0e8584ee85cd8a44daf210bee75d /modules/Makefile
parentcb7734d4080f3673a34594ee4c6e7b02dcd89f33 (diff)
Relevant BUGIDs: 490938
Purpose of commit: new feature Commit summary: --------------- Added libpammodutil and link it with every module as its built. The issue here is that there is a lot of code that the various modules use in common, and this staic library can be used to help make this code more maintainable. I do not intend to make this library dynamic. Especially right now, as I want to be free to chop and change the API and don't want to deal with revision control and third party modules. This checkin makes the pam_rhost_auth module make some use of this new library. I don't intend to add support for any other module prior to releasing 0.76.
Diffstat (limited to 'modules/Makefile')
-rw-r--r--modules/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/modules/Makefile b/modules/Makefile
index 51964e5b..93891029 100644
--- a/modules/Makefile
+++ b/modules/Makefile
@@ -11,6 +11,8 @@ include ../Make.Rules
MODDIRS=$(shell /bin/ls -d pam_*)
all:
+ @echo building the static modutil library
+ make -C pammodutil all
@echo modules sources available are:
@ls -d $(MODDIRS) 2>/dev/null ; echo :--------
@echo
@@ -52,5 +54,5 @@ clean: lclean
if [ -d $$i ]; then { \
$(MAKE) -C $$i clean ; \
} fi ; \
- done
-
+ done
+ make -C pammodutil clean