summaryrefslogtreecommitdiff
path: root/modules/pam_access/Makefile.am
diff options
context:
space:
mode:
authorTomas Mraz <tmraz@fedoraproject.org>2017-05-31 10:27:28 +0200
committerTomas Mraz <tmraz@fedoraproject.org>2017-05-31 10:27:28 +0200
commit7d0c508a52ebc9c702e1b6e66f46e4a6dc028c4a (patch)
tree8baa315fe88b9602c43e2369c3c011ef10bc18c2 /modules/pam_access/Makefile.am
parent5a6a2d169c06cd7e1959c34261d637c3f1c1f573 (diff)
pam_access: support parsing files in /etc/security/access.d/*.conf
* modules/pam_access/pam_access.c (login_access): Return NOMATCH if there was no match in the parsed file. (pam_sm_authenticate): Add glob() call to go through the ACCESS_CONF_GLOB subdirectory and call login_access() on the individual files matched. * modules/pam_access/pam_access.8.xml: Document the addition. * modules/pam_access/Makefile.am: Add ACCESS_CONF_GLOB definition.
Diffstat (limited to 'modules/pam_access/Makefile.am')
-rw-r--r--modules/pam_access/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/modules/pam_access/Makefile.am b/modules/pam_access/Makefile.am
index 6c0f738e..924b7219 100644
--- a/modules/pam_access/Makefile.am
+++ b/modules/pam_access/Makefile.am
@@ -15,7 +15,8 @@ securelibdir = $(SECUREDIR)
secureconfdir = $(SCONFIGDIR)
AM_CFLAGS = -I$(top_srcdir)/libpam/include -I$(top_srcdir)/libpamc/include \
- -DPAM_ACCESS_CONFIG=\"$(SCONFIGDIR)/access.conf\"
+ -DPAM_ACCESS_CONFIG=\"$(SCONFIGDIR)/access.conf\" \
+ -DACCESS_CONF_GLOB=\"$(SCONFIGDIR)/access.d/*.conf\"
AM_LDFLAGS = -no-undefined -avoid-version -module
if HAVE_VERSIONING
AM_LDFLAGS += -Wl,--version-script=$(srcdir)/../modules.map