summaryrefslogtreecommitdiff
path: root/modules/pam_access/pam_access.c
diff options
context:
space:
mode:
authorTomas Mraz <tm@t8m.info>2006-07-03 07:23:29 +0000
committerTomas Mraz <tm@t8m.info>2006-07-03 07:23:29 +0000
commitc938ec2c5c0a796c4a69b8946884a49e266bdea2 (patch)
tree419763ebc8b35659f9ce8caaee46dd573a56a28c /modules/pam_access/pam_access.c
parenta423aae3786fa53b9db66865b603cf21955f37d7 (diff)
Relevant BUGIDs:
Purpose of commit: bugfix Commit summary: --------------- * configure.in: Fixed have_key_syscalls test. * modules/pam_access/pam_access.c (from_match): Fixed IPv4 network match, removed AI_ADDRCONFIG flag.
Diffstat (limited to 'modules/pam_access/pam_access.c')
-rw-r--r--modules/pam_access/pam_access.c8
1 files changed, 4 insertions, 4 deletions
diff --git a/modules/pam_access/pam_access.c b/modules/pam_access/pam_access.c
index 2218ca9a..ffb3c353 100644
--- a/modules/pam_access/pam_access.c
+++ b/modules/pam_access/pam_access.c
@@ -535,7 +535,7 @@ from_match (pam_handle_t *pamh UNUSED, char *tok, struct login_info *item)
struct addrinfo hint;
memset (&hint, '\0', sizeof (hint));
- hint.ai_flags = AI_ADDRCONFIG | AI_CANONNAME;
+ hint.ai_flags = AI_CANONNAME;
hint.ai_family = AF_INET;
if (getaddrinfo (string, NULL, &hint, &res) != 0)
@@ -561,10 +561,10 @@ from_match (pam_handle_t *pamh UNUSED, char *tok, struct login_info *item)
freeaddrinfo (res);
return YES;
}
- runp = runp->ai_next;
}
- freeaddrinfo (res);
+ runp = runp->ai_next;
}
+ freeaddrinfo (res);
}
} else if (isipaddr(string, NULL, NULL) == YES) {
/* Assume network/netmask with a IP of a host. */
@@ -576,7 +576,7 @@ from_match (pam_handle_t *pamh UNUSED, char *tok, struct login_info *item)
struct addrinfo hint;
memset (&hint, '\0', sizeof (hint));
- hint.ai_flags = AI_ADDRCONFIG | AI_CANONNAME;
+ hint.ai_flags = AI_CANONNAME;
hint.ai_family = AF_UNSPEC;
if (getaddrinfo (string, NULL, &hint, &res) != 0)