summaryrefslogtreecommitdiff
path: root/modules/pam_cracklib/Makefile
diff options
context:
space:
mode:
authorAndrew G. Morgan <morgan@kernel.org>2001-02-10 22:15:23 +0000
committerAndrew G. Morgan <morgan@kernel.org>2001-02-10 22:15:23 +0000
commita4632111a5e8e107dcbd759f007cbd9cc5147b72 (patch)
tree1f8432bd39ad6c4c36f4f412c6833111aa52f774 /modules/pam_cracklib/Makefile
parentd66ecd8caf597bcc794f9b9b1716a4f4ab4cfed2 (diff)
Relevant BUGIDs: 131601
Purpose of commit: bugfix Commit summary: --------------- On systems that have a separate libcrypt. This module needed to be linked against it.
Diffstat (limited to 'modules/pam_cracklib/Makefile')
-rw-r--r--modules/pam_cracklib/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/modules/pam_cracklib/Makefile b/modules/pam_cracklib/Makefile
index c279857c..5f6371ef 100644
--- a/modules/pam_cracklib/Makefile
+++ b/modules/pam_cracklib/Makefile
@@ -5,7 +5,7 @@
# Linux-PAM. You should not modify this Makefile (unless you know
# what you are doing!).
#
-# Created by Andrew Morgan <morgan@linux.kernel.org> 2000/10/08
+# Created by Andrew Morgan <morgan@kernel.org> 2000/10/08
#
include ../../Make.Rules
@@ -18,8 +18,9 @@ MODULE_SIMPLE_EXTRALIBS=-lcrack
# These two should really be provided by ../../pam_aconf.h
CFLAGS+=-DCRACKLIB_DICTPATH=\"$(CRACKLIB_DICTPATH)\"
+
ifeq ($(HAVE_LIBCRYPT),yes)
- CFLAGS+=-DNEED_CRYPT_HEADER
+ MODULE_SIMPLE_EXTRALIBS += -lcrypt
endif
endif