summaryrefslogtreecommitdiff
path: root/modules/pam_debug/README
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2006-06-17 17:20:39 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2006-06-17 17:20:39 +0000
commit03226fd971126dfe527a0828c8c6648e94fa613d (patch)
tree97fec3b8e99a9fa776f88de99094fadbc0d977ba /modules/pam_debug/README
parent97f5514b75745ee78428d0d3e46ffb7bc21d4f51 (diff)
Relevant BUGIDs:
Purpose of commit: new feature Commit summary: --------------- 2006-06-17 Thorsten Kukuk <kukuk@thkukuk.de> * modules/pam_debug/Makefile.am: Include Make.xml.rules. * modules/pam_debug/pam_debug.8.xml: New. * modules/pam_debug/pam_debug.8: New, generated from xml file. * modules/pam_debug/README.xml: New. * modules/pam_debug/README: Regenerated from xml file.
Diffstat (limited to 'modules/pam_debug/README')
-rw-r--r--modules/pam_debug/README61
1 files changed, 55 insertions, 6 deletions
diff --git a/modules/pam_debug/README b/modules/pam_debug/README
index b537e3a7..4afff114 100644
--- a/modules/pam_debug/README
+++ b/modules/pam_debug/README
@@ -1,15 +1,64 @@
-# $Id$
-#
+pam_debug — PAM module to debug the PAM stack
-This module returns what its module arguments tell it to return. It
-can be used for debugging libpam and/or an application.
+━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
-Here are some example ways to use it:
+DESCRIPTION
-auth requisite pam_permit.so
+The pam_debug PAM module is intended as a debugging aide for determining how
+the PAM stack is operating. This module returns what its module arguments tell
+it to return.
+
+OPTIONS
+
+auth=value
+
+ The pam_sm_authenticate(3) function will return value.
+
+cred=value
+
+ The pam_sm_setcred(3) function will return value.
+
+acct=value
+
+ The pam_sm_acct_mgmt(3) function will return value.
+
+prechauthtok=value
+
+ The pam_sm_chauthtok(3) function will return value if the PAM_PRELIM_CHECK
+ flag is set.
+
+chauthtok=value
+
+ The pam_sm_chauthtok(3) function will return value if the PAM_PRELIM_CHECK
+ flag is not set.
+
+open_session=value
+
+ The pam_sm_open_session(3) function will return value.
+
+close_session=value
+
+ The pam_sm_close_session(3) function will return value.
+
+Where value can be one of: success, open_err, symbol_err, service_err,
+system_err, buf_err, perm_denied, auth_err, cred_insufficient,
+authinfo_unavail, user_unknown, maxtries, new_authtok_reqd, acct_expired,
+session_err, cred_unavail, cred_expired, cred_err, no_module_data, conv_err,
+authtok_err, authtok_recover_err, authtok_lock_busy, authtok_disable_aging,
+try_again, ignore, abort, authtok_expired, module_unknown, bad_item,
+conv_again, incomplete.
+
+EXAMPLES
+
+auth requisite pam_permit.so
auth [success=2 default=ok] pam_debug.so auth=perm_denied cred=success
auth [default=reset] pam_debug.so auth=success cred=perm_denied
auth [success=done default=die] pam_debug.so
auth optional pam_debug.so auth=perm_denied cred=perm_denied
auth sufficient pam_debug.so auth=success cred=success
+
+AUTHOR
+
+pam_debug was written by Andrew G. Morgan <morgan@kernel.org>.
+